  <!DOCTYPE html>
        <html lang="en">
        <head>
<base href="https://www.rocketminer.com/content/tncms/live/" />
<meta name="keywords" content="columnists" />
<meta name="news_keywords" content="columnists" />
<meta name="description" content="DEAR ABBY: My boyfriend and I have been dating for nearly two years. He would literally do anything for me. He's incredibly affectionate and supportive, and a lot of women" />
<meta name="author" content="" />
<meta name="viewport" content="width=device-width, initial-scale=1.0, maximum-scale=1, user-scalable=0, shrink-to-fit=no" />
<meta name="apple-mobile-web-app-capable" content="yes" />
<meta name="apple-mobile-web-app-status-bar-style" content="black-translucent" />
<meta property="og:type" content="article" />
<meta property="og:url" content="https://www.rocketminer.com/opinion/columnists/dear-abby-for-july/article_d72b5be0-8023-593f-b2bb-c3de57fe9957.html" />
<meta property="og:image" content="https://bloximages.chicago2.vip.townnews.com/rocketminer.com/content/tncms/custom/image/0be4b2fa-ee45-11e6-8d25-fb5ddfaadb65.jpg" />
<meta property="og:image:width" content="979" />
<meta property="og:image:height" content="979" />
<meta property="og:title" content="Dear Abby for July 22, 2019" />
<meta property="og:description" content="DEAR ABBY: My boyfriend and I have been dating for nearly two years. He would literally do anything for me. He's incredibly affectionate and supportive, and a lot of women" />
<meta property="og:site_name" content="rocketminer.com" />
<meta property="og:section" content="Columnists" />
<meta property="article:publisher" content="https://www.facebook.com/rocketminernewspaper/" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:site" content="@Rocket_Miner" />
<link rel="stylesheet preload" as="style" href="https://bloximages.chicago2.vip.townnews.com/rocketminer.com/shared-content/art/tncms/templates/libraries/flex/components/bootstrap/resources/styles/bootstrap.min.8aebbe9627939cd5a7c8e4f6930a23bd.css"/>
<link rel="stylesheet preload" as="style" href="https://bloximages.chicago2.vip.townnews.com/rocketminer.com/shared-content/art/tncms/templates/libraries/flex/components/template/resources/styles/layout.f85bdd8ecb1a515ca678ac2197765d61.css"/>
<link rel="stylesheet preload" as="style" href="https://bloximages.chicago2.vip.townnews.com/rocketminer.com/shared-content/art/tncms/templates/libraries/flex/components/themes/resources/styles/theme-basic.4cce04b95f9b49884d7452d4a02f3f09.css"/>
<link rel="stylesheet" href="https://bloximages.chicago2.vip.townnews.com/rocketminer.com/content/tncms/live/global/resources/styles/site.css?_dc=1475503981"/>
<link rel="stylesheet" href="https://bloximages.chicago2.vip.townnews.com/rocketminer.com/shared-content/art/tncms/templates/libraries/flex/components/comments/resources/styles/tnt.comments.c281ededc640381d48e91e027585814d.css"/>
<link rel="stylesheet preload" as="style" href="https://bloximages.chicago2.vip.townnews.com/rocketminer.com/shared-content/art/tncms/templates/libraries/flex/components/block/resources/styles/flex-utility-text-promo.945a2efac4892ce469180c513f411107.css"/>
<link rel="stylesheet" href="https://bloximages.chicago2.vip.townnews.com/rocketminer.com/shared-content/art/tncms/templates/libraries/flex/components/plugins/resources/styles/tntslider.ccf0e59695df670a0ab3c05d3402fa4c.css"/>
<link rel="stylesheet preload" as="style" href="https://bloximages.chicago2.vip.townnews.com/rocketminer.com/shared-content/art/tncms/templates/libraries/flex/components/block/resources/styles/flex-classifieds-bulletins.5f446bdd20135c51eaa9a71a41a3a657.css"/>
<style>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</style>
<script type="text/javascript">(function(){var tnsrc=window.location.hash.match(/[&#]tncms-source=([^&]+)/);var dl = window.dataLayer = window.dataLayer || [];dl.push({"tncms":{"template":{"version":"3.141.0"},"page":{"grid":"boxy","style":"default","path":"\/opinion\/columnists","syndicated":"false","reaction":"false","app":"editorial","theme":"flex","skin":"flex-editorial","http_status":200},"subscription":{"required":"false"},"vendor":{"outbrain":"Headlines and photo grid","taboola":""},"system":{"render_time":238},"client":{"is_bot":"no","is_gdpr":"no"}}});if (tnsrc && tnsrc[1]) {dl.push({'tncms.campaign.internal_source': tnsrc[1]});}window.addEventListener("DOMContentLoaded", function(oEvent) {var oTest = document.createElement('div');oTest.innerHTML = '&nbsp;';oTest.className = 'adsbox';document.body.appendChild(oTest);var nTimeoutID = window.setTimeout(function() {if (oTest.offsetHeight === 0) {dl.push({'event': 'tncms.ad.blocked'});}document.body.removeChild(oTest);window.clearTimeout(nTimeoutID);}, 100);});var nWidth=Math.max(document.documentElement.clientWidth, window.innerWidth || 0),aBPs=[[300,"Extra small: Most smartphones."],[768,"Small: Tablet devices."],[992,"Medium: Laptops & landscape tablets."],[1200,"Large: Desktop computers."]],i,c,aThisBP,aBP;for(i=0,c=aBPs.length;i<c;i++){aThisBP=aBPs[i];if(aBP===undefined||aThisBP[0]<=nWidth){aBP=aThisBP;}}if(aBP!==undefined){dl.push({'tncms.client.breakpoint':aBP[1]});}(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'tncms.start':new Date().getTime(),event:'tncms.start'});var f=d.getElementsByTagName(s)[0],j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src='https://www.googletagmanager.com/gtm.js?id='+i+dl+ '&gtm_auth=UaWpb3d_PDCaIVzoLRLRYA&gtm_preview=env-2&gtm_cookies_win=x';f.parentNode.insertBefore(j,f);})(window,document,'script','dataLayer','GTM-PDQV3N');})();</script>
<script src="/shared-content/art/tncms/user/user.js"></script>
<script src="/shared-content/art/tncms/tracking.js"></script>
<script src="/shared-content/art/tncms/subscription.js"></script>
<script>/*<![CDATA[*/ TNCMS.Subscription.initialize({"service_id": "4995,5033,5029", "prefix": ""}); /*]]>*/</script>
<script src="https://bloximages.chicago2.vip.townnews.com/rocketminer.com/shared-content/art/tncms/templates/libraries/flex/components/jquery/resources/scripts/jquery.min.d1a4f9eb1701d7bb8dd985a2ca0981e5.js"></script>
<script>/*<![CDATA[*/ TNCMS.User.restorePersistentSession(); /*]]>*/</script>
<script src="https://bloximages.chicago2.vip.townnews.com/rocketminer.com/shared-content/art/tncms/templates/libraries/flex/components/bootstrap/resources/scripts/bootstrap.min.9ef2deb39dff2c51bd3efbbfc097b065.js"></script>
<script src="https://bloximages.chicago2.vip.townnews.com/rocketminer.com/shared-content/art/tncms/templates/libraries/flex/components/plugins/resources/scripts/common.2298fa2c06ac9b301ef502070168c6dc.js"></script>
<script src="https://bloximages.chicago2.vip.townnews.com/rocketminer.com/shared-content/art/tncms/templates/libraries/flex/components/template/resources/scripts/tnt.9329546da5f585bc9c9c9b7f9d6df105.js"></script>
<script src="https://bloximages.chicago2.vip.townnews.com/rocketminer.com/shared-content/art/tncms/templates/libraries/flex/components/template/resources/scripts/application.cb8ce7db3d97ee68fa83a4ab2b12db43.js"></script>
<script>/*<![CDATA[*/ (function(d,w,s){
        if(w.fetch&&w.Promise&&w.IntersectionObserver&&[].includes&&Object.assign&&w.Map&&w.NodeList)return;
        var sc=d.getElementsByTagName(s)[0],js=d.createElement(s);
        js.src='https://polyfill.io/v3/polyfill.min.js?features=default,fetch,IntersectionObserver,NodeList.prototype.@@iterator';
        sc.parentNode.insertBefore(js, sc);
    }(document,window,'script')) /*]]>*/</script>
<script async="async" src="https://securepubads.g.doubleclick.net/tag/js/gpt.js"></script>
<script>/*<![CDATA[*/ window.googletag = window.googletag || {cmd: []};
    window.gptAdSlots = window.gptAdSlots || [];
    
    var __tnt = __tnt || {};
    __tnt.ads = __tnt.ads || {};
    __tnt.ads.dfp = __tnt.ads.dfp || {};
    __tnt.ads.dfp.targeting = __tnt.ads.dfp.targeting || {};
    __tnt.ads.dfp.templates = __tnt.ads.dfp.templates || {};
    __tnt.ads.dfp.targeting.k = ["columnists"];
    __tnt.ads.dfp.targeting.page = ["asset","article","app-editorial"];
    __tnt.ads.dfp.templates = {
        interstitial:"https:\/\/bloximages.chicago2.vip.townnews.com\/rocketminer.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/ads_dfp\/resources\/scripts\/templates\/interstitial.36770bdfae09a8898776cd45ffd261f5.js",
        pageCurl:"https:\/\/bloximages.chicago2.vip.townnews.com\/rocketminer.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/ads_dfp\/resources\/scripts\/templates\/page-curl.ca0c1a7372c29272ef1ccf504ced01a9.js",
        parallax:"https:\/\/bloximages.chicago2.vip.townnews.com\/rocketminer.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/ads_dfp\/resources\/scripts\/templates\/parallax.562ac43ab5c59b0f315e3f7aabdfac51.js",
        paw:"https:\/\/bloximages.chicago2.vip.townnews.com\/rocketminer.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/ads_dfp\/resources\/scripts\/templates\/paw.8e53564c4372008ce3ae3c43f6d8e16d.js",
        pencil:"https:\/\/bloximages.chicago2.vip.townnews.com\/rocketminer.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/ads_dfp\/resources\/scripts\/templates\/pencil.4ad5149d4e4a5e7661c8596fd9dbfce4.js",
        reveal:"https:\/\/bloximages.chicago2.vip.townnews.com\/rocketminer.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/ads_dfp\/resources\/scripts\/templates\/reveal.595ef762ed8eb508161be05ea8d978ef.js",
        wallpaper:"https:\/\/bloximages.chicago2.vip.townnews.com\/rocketminer.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/ads_dfp\/resources\/scripts\/templates\/wallpaper.9afeb985d16cbfcba854ed7453649262.js"
    }; /*]]>*/</script>
<script>/*<![CDATA[*/ 
    googletag.cmd.push(function(){
            var adUnit = (window.frameElement && window.frameElement.getAttribute('data-gam-adunit')) ? window.frameElement.getAttribute('data-gam-adunit') : '7569944/rocketminer_wallpaper_skin';
            
                gptAdSlots['ad-1541041'] = googletag.defineSlot(adUnit, [1, 1], 'ad-1541041').setCollapseEmptyDiv(true).addService(googletag.pubads());
    });
 /*]]>*/</script>
<script src="https://bloximages.chicago2.vip.townnews.com/rocketminer.com/shared-content/art/tncms/templates/libraries/flex/components/ads_blox/resources/scripts/tnt.ads.init.6cc3c6b5c89c0c6e8d3e48f50b65f875.js"></script>
<script async="async" src="https://bloximages.chicago2.vip.townnews.com/rocketminer.com/shared-content/art/tncms/templates/libraries/flex/components/ads_blox/resources/scripts/tnt.ads.load.6a3c47703ee96f20ef132e36033ca1bc.js"></script>
<script src="/shared-content/art/tncms-ad-manager/admanager.js"></script>
<script src="https://bloximages.chicago2.vip.townnews.com/rocketminer.com/content/tncms/ads/impressions.js?_dc=1563764756"></script>
<script src="https://bloximages.chicago2.vip.townnews.com/rocketminer.com/content/tncms/ads/traffic.js?_dc=1563690956"></script>
<script src="https://bloximages.chicago2.vip.townnews.com/rocketminer.com/content/tncms/ads/settings.js?_dc=1553183275"></script>
<script async="async" src="https://bloximages.chicago2.vip.townnews.com/rocketminer.com/shared-content/art/tncms/templates/libraries/flex/components/plugins/resources/scripts/sms-link.8eefede3265fd6c6de07bc0cb5f3f779.js"></script>
<script src="https://bloximages.chicago2.vip.townnews.com/rocketminer.com/shared-content/art/tncms/templates/libraries/flex/components/comments/resources/scripts/tnt.comment.89c459acbb5b3f64e6ad65972d5f7da0.js"></script>
<script src="https://bloximages.chicago2.vip.townnews.com/rocketminer.com/shared-content/art/tncms/templates/libraries/flex/components/comments/resources/scripts/tnt.emoticons.2048520c3a5ad423f37d8d4ac8c790a9.js"></script>
<script async="async" src="https://bloximages.chicago2.vip.townnews.com/rocketminer.com/shared-content/art/tncms/templates/libraries/flex/components/plugins/resources/scripts/tntslider.4a4b64a2b096ed15ec9b6b389f751155.js"></script>
<script async="async" src="https://bloximages.chicago2.vip.townnews.com/rocketminer.com/shared-content/art/tncms/templates/libraries/flex/components/plugins/resources/scripts/ie.grid.placement.8d31e32afeebe4520bfab9638ef91435.js"></script>
<script>/*<![CDATA[*/ 
    googletag.cmd.push(function(){
            var adUnit = (window.frameElement && window.frameElement.getAttribute('data-gam-adunit')) ? window.frameElement.getAttribute('data-gam-adunit') : '140244687/fixed-leaderboard-bottom';
            
                gptAdSlots['ad-1379860'] = googletag.defineSlot(adUnit, [728, 90], 'ad-1379860').setCollapseEmptyDiv(true).addService(googletag.pubads());
    });
 /*]]>*/</script>
<script src="https://bloximages.chicago2.vip.townnews.com/rocketminer.com/shared-content/art/tncms/templates/libraries/flex/components/ads/resources/scripts/tnt.ads.advertisements.66a3812a7b5c12fde8cd998fd691ad7d.js"></script>
<script>/*<![CDATA[*/ 
    googletag.cmd.push(function() {
        if (__tnt.ads.dfp.targeting) {
            for (var k in __tnt.ads.dfp.targeting) {
                if (__tnt.ads.dfp.targeting.hasOwnProperty(k)) {
                    googletag.pubads().setTargeting(k,__tnt.ads.dfp.targeting[k]);
                }
            }
        }

        googletag.pubads().enableSingleRequest();
        googletag.enableServices();
    });

    
 /*]]>*/</script>

            
            <title>Dear Abby for July 22, 2019 | Columnists | rocketminer.com</title>
            
    <style>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</style>
    
        <link rel="shortcut icon" type="image/x-icon" href="https://www.rocketminer.com/content/tncms/site/icon.ico" />
    
        <link rel="apple-touch-icon" href="https://bloximages.chicago2.vip.townnews.com/rocketminer.com/content/tncms/custom/image/2b8540c8-8975-11e6-a028-5b7403d9d6c0.png?resize=180%2C180" />
    
        <link rel="dns-prefetch preconnect" href="//www.google.com">
    
        <link rel="dns-prefetch preconnect" href="//adservice.google.com">
    
        <link rel="dns-prefetch preconnect" href="//securepubads.g.doubleclick.net">
    
        <link rel="dns-prefetch preconnect" href="//stats.g.doubleclick.net">
    
        <link rel="dns-prefetch preconnect" href="//tpc.googlesyndication.com">
    
        <link rel="dns-prefetch preconnect" href="//pagead2.googlesyndication.com">
    
        <link rel="dns-prefetch preconnect" href="//s.yimg.com">
    
        <link rel="dns-prefetch preconnect" href="//cdn.taboola.com">
    
        <link rel="dns-prefetch preconnect" href="//www.googletagmanager.com">
    
        <link rel="dns-prefetch preconnect" href="//www.google-analytics.com">
    <link rel="alternate" type="application/rss+xml" title="Dear Abby for July 22, 2019 | Columnists | rocketminer.com" href="http://www.rocketminer.com/search/?f=rss&amp;t=article&amp;c=opinion/columnists&amp;l=50&amp;s=start_time&amp;sd=desc" />
    <link rel="canonical" href="https://www.rocketminer.com/opinion/columnists/dear-abby-for-july/article_d72b5be0-8023-593f-b2bb-c3de57fe9957.html" />
            
    <script defer src="https://bloximages.chicago2.vip.townnews.com/rocketminer.com/shared-content/art/tncms/templates/libraries/flex/components/plugins/resources/scripts/fontawesome.4a9fdca450d57375be3be7a06b5bc5f0.js"></script>
            
        </head>
        <body class=" blox-asset app-editorial uuid-d72b5be0-8023-593f-b2bb-c3de57fe9957  section-opinion section-columnists type-article infinity-disabled">
	<script type='text/javascript' src='/shared-content/art/stats/common/tracker.js'></script>
	<script type='text/javascript'>
	<!--
	if (typeof(TNStats_Tracker) !== 'undefined' && typeof(TNTracker) === 'undefined') { TNTracker = new TNStats_Tracker('www.rocketminer.com'); TNTracker.trackPageView(); }
	// -->
	</script>
	<noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-PDQV3N&tncms.template.version=3.141.0&tncms.page.grid=boxy&tncms.page.style=default&tncms.page.path=%2Fopinion%2Fcolumnists&tncms.page.syndicated=false&tncms.page.reaction=false&tncms.page.app=editorial&tncms.page.theme=flex&tncms.page.skin=flex-editorial&tncms.page.http_status=200&tncms.subscription.required=false&tncms.vendor.outbrain=Headlines+and+photo+grid&tncms.vendor.taboola=&tncms.system.render_time=238&tncms.client.is_bot=no&tncms.client.is_gdpr=no&tncms.client.noscript=yes" height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
        
        
        <!-- Google Tag Manager -->
        <script>
            var dataLayer = window.dataLayer || [];
            dataLayer.push(
                {'user_id': __tnt.user.screenName},
                {'user_state': __tnt.user.loggedIn ? 'logged in' : 'anonymous'},
                {'utm_label': __tnt.urlHash('utm_label')}
            );
        </script>
        <noscript><iframe src="//www.googletagmanager.com/ns.html?id=" height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
        <script>
            (function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
            new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
            j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
            '//www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
            })(window,document,'script','dataLayer','');
        </script>
        <script>
            $(function(){
                var bloxServiceIDs = [];
                var bloxUserServiceIds = [];
                var dataLayer = window.dataLayer || [];

                
                bloxServiceIDs.push(4995);
                
                bloxServiceIDs.push(5033);
                
                bloxServiceIDs.push(5029);
                

                if (__tnt.user.services){
                    var bloxUserServiceIDs = __tnt.user.services.replace('%2C',',').split(',');
                }

                // GTM tncms.subscription.paid_access_service_ids
                if(bloxServiceIDs){
                    dataLayer.push({'tncms':{'subscription':{'access_service_ids':bloxServiceIDs.toString()}}});
                }

                // GTM tncms.subscrption.user_service_ids
                if(bloxUserServiceIDs){
                    dataLayer.push({'tncms':{'subscription':{'user_service_ids':bloxUserServiceIDs.toString()}}});
                }
            });
        </script>
        
        <div id="site-container"><div id="asset-edit-container-d72b5be0-8023-593f-b2bb-c3de57fe9957" class="asset-owner-content asset-edit-container progress hidden-print">
            <div class="progress-bar progress-bar-primary progress-bar-striped">
                <div class="asset-edit-icon pull-left hidden-sm hidden-xs"><i class="fas tnt-certificate"></i></div>
                <div class="asset-edit-message pull-left">You are the owner of this article.</div>
                <div class="asset-edit-btns pull-right">
                    <a class="btn btn-primary" href="https://www.rocketminer.com/users/admin/contribute/article/?assetid=d72b5be0-8023-593f-b2bb-c3de57fe9957&assettype=article"><i class="fas tnt-pen-square"></i> Edit Article</a>
                    
                        <a class="btn btn-danger" href="https://www.rocketminer.com/users/admin/contribute/article/?from_section=/opinion/columnists"><i class="fas tnt-plus-square"></i> Add New Article</a>
                    
                </div>
                <div class="clearfix"></div>
            </div>
        </div><script>
        var oAuthors = [];jQuery(document).ready(function($){
            if( __tnt.user.loggedIn && jQuery.inArray(__tnt.user.screenName, oAuthors) !==-1 ){
                __tnt.isAuthor = true;
                $('.asset-owner-content').show();
            }
        });
    </script>

    
        
        
           <aside class="hidden-print offcanvas-drawer offcanvas-drawer-right visible-sm visible-xs">
                <div id="tncms-region-mobile-nav-top-right-region" class="tncms-region "><div id="tncms-block-1305572" class="tncms-block hidden-md hidden-lg"><div id="user-controls-1305572" class="user-controls show-onload clearfix default"><div class="not-logged-in">
        <ul class="list-inline"><li><a href="https://www.rocketminer.com/users/signup/?referer_url=https%3A%2F%2Fwww.rocketminer.com%2Fopinion%2Fcolumnists%2Fdear-abby-for-july%2Farticle_d72b5be0-8023-593f-b2bb-c3de57fe9957.html" class="btn btn-link btn-sm user-control-link" rel="nofollow">Sign Up</a></li><li>
                    <a href="https://www.rocketminer.com/users/login/?referer_url=https%3A%2F%2Fwww.rocketminer.com%2Fopinion%2Fcolumnists%2Fdear-abby-for-july%2Farticle_d72b5be0-8023-593f-b2bb-c3de57fe9957.html" class="btn btn-primary btn-sm login-btn user-control-link" rel="nofollow">
                        Log In
                    </a></li>
        </ul>
    </div>

    <div class="logged-in">
        
        
            <div class="hide show-offcanvas">
                <ul class="list-inline">
                    <li><a href="https://www.rocketminer.com/users/admin/" class="btn btn-primary btn-sm login-btn user-control-link">Dashboard</a></li>
                    <li> <a class="btn btn-link btn-sm user-control-link" onclick="jQuery('#user-logout-form-1305572').submit(); return false;" rel="nofollow"> Logout</a></li>
                </ul>
            </div>
        
        <ul class="hide-offcanvas list-inline">
            <li class="dropdown pull-right">
                
                <div class="dropdown-toggle btn btn-link btn-sm user-dropdown" data-toggle="dropdown" data-hover="dropdown" data-hover-delay="250"><div class="tn-user-avatar pull-left"><!-- user avatar --></div><span class="tn-user-screenname pull-left"></span><b class="caret user-control-link"></b>
                </div>
                <ul class="dropdown-menu dropdown-menu-right" role="menu">
                    <li role="presentation" class="dropdown-header">My Account</li>
                    <li><a href="https://www.rocketminer.com/users/admin/" rel="nofollow"><i class="fas tnt-tachometer-alt tnt-fw"></i> Dashboard</a></li>
                    <li><a class="tn-user-profile-url" href="" data-app="https://www.rocketminer.com/users/"><i class="fas tnt-user tnt-fw"></i> Profile</a></li>
                    <li><a href="https://www.rocketminer.com/users/admin/list/" rel="nofollow"><i class="fas tnt-bookmark tnt-fw"></i> Saved items</a></li>
                    <li role="presentation" class="divider"></li>
                    <li><a class="logout-btn" onclick="jQuery('#user-logout-form-1305572').submit(); return false;" rel="nofollow"><i class="fas tnt-power-off tnt-fw"></i> Logout</a></li>
                </ul>
            </li>
        </ul>
    </div>
</div>

<form method="post" action="https://www.rocketminer.com/users/logout/" id="user-logout-form-1305572"><input type="hidden" name="referer_url" value="https://www.rocketminer.com/opinion/columnists/dear-abby-for-july/article_d72b5be0-8023-593f-b2bb-c3de57fe9957.html"><input type="submit" name="logout" value="Logout" class="hide">
</form></div></div>
                <div id="tncms-region-nav-mobile-nav-right" class="tncms-region-nav"><div id="mobile-nav-right_menu" class="panel-group nav navbar-nav" role="tablist"><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a data-toggle="collapse" class="expand-children collapsed pull-right" aria-expanded="false" aria-controls="mobile-nav-right_menu-child-1" data-target="#mobile-nav-right_menu-child-1">
                                    <i class="fas tnt-chevron-down"></i>
                                </a><a href="/"  class="nav-link tnt-section-home">Home</a>
                        </div>
                    </div><ul id="mobile-nav-right_menu-child-1" class="collapse nav navbar-nav"><li>
                                    <a href="/site/about.html"  class="nav-link tnt-section-about-us">About Us</a>
                                </li><li>
                                    <a href="/site/contact.html"  class="nav-link tnt-section-contact-us">Contact Us</a>
                                </li><li>
                                    <a href="/site/forms/subscription_services/"  class="nav-link tnt-section-subscribe">Subscribe</a>
                                </li><li>
                                    <a href="/eedition/"  class="nav-link tnt-section-e-edition">e-Edition</a>
                                </li><li>
                                    <a   class="nav-link tnt-section-partner-papers">Partner Papers</a>
                                </li><li>
                                    <a   class="nav-link tnt-section-employment">Employment</a>
                                </li><li>
                                    <a href="/site/faq.html"  class="nav-link tnt-section-faq">FAQ</a>
                                </li></ul></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a data-toggle="collapse" class="expand-children collapsed pull-right" aria-expanded="false" aria-controls="mobile-nav-right_menu-child-2" data-target="#mobile-nav-right_menu-child-2">
                                    <i class="fas tnt-chevron-down"></i>
                                </a><a href="/news/"  class="nav-link tnt-section-news">News</a>
                        </div>
                    </div><ul id="mobile-nav-right_menu-child-2" class="collapse nav navbar-nav"><li>
                                    <a href="/news/local/"  class="nav-link tnt-section-local-news">Local News</a>
                                </li><li>
                                    <a href="/news/national/"  class="nav-link tnt-section-national">National</a>
                                </li><li>
                                    <a href="/news/world/"  class="nav-link tnt-section-world">World</a>
                                </li><li>
                                    <a href="/news/state/"  class="nav-link tnt-section-state">State</a>
                                </li><li>
                                    <a href="/elections/"  class="nav-link tnt-section-elections">Elections</a>
                                </li><li>
                                    <a href="/multimedia/photo_galleries"  class="nav-link tnt-section-photo-galleries">Photo Galleries</a>
                                </li><li>
                                    <a href="/special/"  class="nav-link tnt-section-special-sections">Special Sections</a>
                                </li><li>
                                    <a href="http://rocketminer.com/users/admin/contribute/article/"  target="_blank" rel="noopener" class="nav-link tnt-section-submit-your-news">Submit Your News</a>
                                </li></ul></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a data-toggle="collapse" class="expand-children collapsed pull-right" aria-expanded="false" aria-controls="mobile-nav-right_menu-child-3" data-target="#mobile-nav-right_menu-child-3">
                                    <i class="fas tnt-chevron-down"></i>
                                </a><a href="/sports/"  class="nav-link tnt-section-sports">Sports</a>
                        </div>
                    </div><ul id="mobile-nav-right_menu-child-3" class="collapse nav navbar-nav"><li>
                                    <a href="/sports/high_schools/"  class="nav-link tnt-section-high-schools">High Schools</a>
                                </li><li>
                                    <a href="/sports/western_wyoming_cc/"  class="nav-link tnt-section-western-wyoming-cc">Western Wyoming CC</a>
                                </li><li>
                                    <a href="/sports/university_of_wyoming/"  class="nav-link tnt-section-university-of-wyoming">University of Wyoming</a>
                                </li><li>
                                    <a href="/sports/community_sports/"  class="nav-link tnt-section-community-sports">Community Sports</a>
                                </li><li>
                                    <a href="/sports/rodeo"  class="nav-link tnt-section-rodeo">Rodeo</a>
                                </li></ul></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a data-toggle="collapse" class="expand-children collapsed pull-right" aria-expanded="false" aria-controls="mobile-nav-right_menu-child-4" data-target="#mobile-nav-right_menu-child-4">
                                    <i class="fas tnt-chevron-down"></i>
                                </a><a href="/opinion/"  class="nav-link tnt-section-opinion">Opinion</a>
                        </div>
                    </div><ul id="mobile-nav-right_menu-child-4" class="collapse nav navbar-nav"><li>
                                    <a href="/opinion/editorials/"  class="nav-link tnt-section-editorials">Editorials</a>
                                </li><li>
                                    <a href="/opinion/letters_to_editor/"  class="nav-link tnt-section-letters-to-the-editor">Letters to the Editor</a>
                                </li><li>
                                    <a href="/opinion/columnists/"  class="nav-link tnt-section-columnists">Columnists</a>
                                </li><li>
                                    <a href="/opinion/cartoons/"  class="nav-link tnt-section-cartoons">Cartoons</a>
                                </li></ul></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a data-toggle="collapse" class="expand-children collapsed pull-right" aria-expanded="false" aria-controls="mobile-nav-right_menu-child-5" data-target="#mobile-nav-right_menu-child-5">
                                    <i class="fas tnt-chevron-down"></i>
                                </a><a href="/community/"  class="nav-link tnt-section-community">Community</a>
                        </div>
                    </div><ul id="mobile-nav-right_menu-child-5" class="collapse nav navbar-nav"><li>
                                    <a href="/calendar/"  class="nav-link tnt-section-calendar">Calendar</a>
                                </li><li>
                                    <a href="/community/club_news_games/"  class="nav-link tnt-section-club-newsgames">Club News/Games</a>
                                </li><li>
                                    <a href="/community/people/"  class="nav-link tnt-section-people">People</a>
                                </li><li>
                                    <a href="/community/entertainment/"  class="nav-link tnt-section-entertainment">Entertainment</a>
                                </li><li>
                                    <a href="/community/your_take/"  class="nav-link tnt-section-your-take">Your Take</a>
                                </li><li>
                                    <a href="/community/senior_menus/"  class="nav-link tnt-section-senior-menus">Senior Menus</a>
                                </li><li>
                                    <a href="/community/school_menus/"  class="nav-link tnt-section-school-menus">School Menus</a>
                                </li><li>
                                    <a href="/community/hospital_menus/"  class="nav-link tnt-section-hospital-menus">Hospital menus</a>
                                </li><li>
                                    <a href="http://map.rocketminer.com"  target="_blank" rel="noopener" class="nav-link tnt-section-community-map">Community Map</a>
                                </li></ul></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a data-toggle="collapse" class="expand-children collapsed pull-right" aria-expanded="false" aria-controls="mobile-nav-right_menu-child-6" data-target="#mobile-nav-right_menu-child-6">
                                    <i class="fas tnt-chevron-down"></i>
                                </a><a   class="nav-link tnt-section-milestones">Milestones</a>
                        </div>
                    </div><ul id="mobile-nav-right_menu-child-6" class="collapse nav navbar-nav"><li>
                                    <a   class="nav-link tnt-section-submit-announcements">Submit Announcements</a>
                                </li><li>
                                    <a   class="nav-link tnt-section-view-announcements">View Announcements</a>
                                </li></ul></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a href="/obituaries/"  class="nav-link tnt-section-obituaries">Obituaries</a>
                        </div>
                    </div></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a data-toggle="collapse" class="expand-children collapsed pull-right" aria-expanded="false" aria-controls="mobile-nav-right_menu-child-8" data-target="#mobile-nav-right_menu-child-8">
                                    <i class="fas tnt-chevron-down"></i>
                                </a><a href="/records/"  class="nav-link tnt-section-records">Records</a>
                        </div>
                    </div><ul id="mobile-nav-right_menu-child-8" class="collapse nav navbar-nav"><li>
                                    <a   class="nav-link tnt-section-arrests">Arrests</a>
                                </li><li>
                                    <a href="/records/sex_offenders/"  class="nav-link tnt-section-sex-offenders">Sex Offenders</a>
                                </li><li>
                                    <a   class="nav-link tnt-section-municipal-courts">Municipal Courts</a>
                                </li><li>
                                    <a   class="nav-link tnt-section-circuit-courts">Circuit Courts</a>
                                </li><li>
                                    <a href="https://sweetwater911.org/apps/jailroster/"  target="_blank" rel="noopener" class="nav-link tnt-section-jail-roster">Jail Roster</a>
                                </li><li>
                                    <a href="/records/judgments/"  class="nav-link tnt-section-judgments">Judgments</a>
                                </li><li>
                                    <a href="/records/marriages/"  class="nav-link tnt-section-marriages">Marriages</a>
                                </li><li>
                                    <a href="/records/divorces/"  class="nav-link tnt-section-divorces">Divorces</a>
                                </li><li>
                                    <a href="/records/warranty_deeds/"  class="nav-link tnt-section-warranty-deeds">Warranty Deeds</a>
                                </li><li>
                                    <a href="/records/valuation_reports/"  class="nav-link tnt-section-valuation_reports">Valuation_reports</a>
                                </li></ul></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a data-toggle="collapse" class="expand-children collapsed pull-right" aria-expanded="false" aria-controls="mobile-nav-right_menu-child-9" data-target="#mobile-nav-right_menu-child-9">
                                    <i class="fas tnt-chevron-down"></i>
                                </a><a   class="nav-link tnt-section-classifieds">Classifieds</a>
                        </div>
                    </div><ul id="mobile-nav-right_menu-child-9" class="collapse nav navbar-nav"><li>
                                    <a href="/classifieds/"  class="nav-link tnt-section-view-classifieds">View Classifieds</a>
                                </li><li>
                                    <a href="http://www.rocketminer.com/classifieds/service/legal/"  target="_blank" rel="noopener" class="nav-link tnt-section-view-legals">View Legals</a>
                                </li><li>
                                    <a href="https://classadz.vdata.com/RockSpringsRocketMiner/Advertising/Advertiser"  target="_blank" rel="noopener" class="nav-link tnt-section-place-an-ad">Place an Ad</a>
                                </li></ul></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a href="/weather/"  class="nav-link tnt-section-weather">Weather</a>
                        </div>
                    </div></div></div></div>
                
                <div id="tncms-region-mobile-nav-bottom-right-region" class="tncms-region "><div id="tncms-block-1305568" class="tncms-block hidden-md hidden-lg"><section id="block-1305568" class="block emphasis-h3   " >
    <div class="clearfix"></div>
    <div id="search-form-1305568" class="search-form-container card clearfix text-center ">
    <form id="site-search-1305568" action="/search/" method="GET" >
    <input type="hidden" name="sd" value="desc">
    <input type="hidden" name="l" value="25">
    
        
        <input type="hidden" name="sort" value="relevance">
    
    
    
    <input type="hidden" name="f" value="html">
    <input type="hidden" name="t" value="article,video,youtube,collection">
    <input type="hidden" name="app" value="editorial">
    <input type="hidden" name="nsa" value="eedition">
    <div class="site-search-form input-group default normal form-control">
        <input id="site-search-1305568-term" name="q" title="Site Search" type="text" placeholder="Search..." class="form-control" autocomplete="off">
        <input type="submit" class="hide" value="Search">
        <span class="input-group-btn">
            <button id="site-search-1305568-btn" class="btn btn-link" aria-label="Submit Site Search" type="submit">
                
            </button>
        </span>
    </div>
    <div class="clearfix"></div>
</form>
        
        
        <div class="clearfix"></div>
    </div>
    </section> 

<script>
    $('#site-search-1305568-btn').on(__tnt.client.clickEvent, function(){
        $('#site-search-1305568').submit();
        return false;
    });

    $('#site-search-1305568').on('submit', function(){
        // Filter query
        var sQueryFiltered = $("#site-search-1305568 input[name=q]").val().replace(/\?/g, '');
    $("#site-search-1305568 input[name=q]").val( sQueryFiltered );

        if( $('#site-search-1305568-term').val() ){
            return true;
        }else{
            return false;
        }
    });</script></div></div>
            </aside>
        

        <div class="offcanvas-inner">
            <div class="offcanvas-close-btn hidden-md hidden-lg"></div>
    

    <div id="tncms-region-asset_skyline" class="tncms-region hidden-print"></div><div id="tncms-region-global-skyline" class="tncms-region "></div>
    

    
        <div id="site-top-nav-container" class="hidden-sm hidden-xs hidden-print">
            <header id="site-top-nav" class="container">
                <div class="row">
                    <div id="topbar-col-one" class="col-md-6 col-sm-6"><div id="tncms-region-topbar-col-one" class="tncms-region "><div id="tncms-block-1355451" class="tncms-block"><style>

/* Paywall Flag customizations  */
.label-flag-web-only
{
background-color: #71b9f1 !important;
position: absolute;
color: #fff !important;
top: 0;
right: 0;
border-radius: 0;
font-size: 80%;
}
.asset-header .label-flag-web-only {
right: 30px;
}
.mosaic-grid .label-flag-web-only {
bottom: 0;
top: initial;
top: auto;
}
.mosaic-grid .mosaic-item .meta {
width: 100%;
}
.mosaic-grid .mosaic-item .byline
{
margin-bottom:10px !important;
}
/* End Paywall Flag Customizations */
</style></div><div id="tncms-block-1355453" class="tncms-block"><script language="javascript" type="text/javascript">

jQuery(document).ready(function(){
$('.label-flag-web-only').text('Open Access'); // Custom Flag for Paywall-bypassed articles

});

</script></div><div id="tncms-block-1541041" class="tncms-block"><div class="tnt-ads-container text-center  " >
        <div id="ad-1541041" class="tnt-ads dfp-ad" >
            <script>
                googletag.cmd.push(function() {
                        googletag.display('ad-1541041');
                        
                });
            </script>
        </div>
    </div>
</div></div><div id="tncms-region-nav-topbar-col-one-nav" class="tncms-region-nav"><ul id="topbar-col-one-nav_menu" class="list-inline nav-list"><li>
                <a class="nav-link  tnt-section-about-us"  href="/site/about.html" >
                    <span class="nav-label">About Us</span>
                </a></li><li>
                <a class="nav-link  tnt-section-contact-us"  href="/site/contact.html" >
                    <span class="nav-label">Contact Us</span>
                </a></li><li>
                <a class="nav-link  tnt-section-subscribe"  href="/site/forms/subscription_services/" >
                    <span class="nav-label">Subscribe</span>
                </a></li><li>
                <a class="nav-link  tnt-section-e-edition"  href="/eedition/" >
                    <span class="nav-label">e-Edition</span>
                </a></li><li>
                <a class="nav-link  tnt-section-special-sections"  href="/special/" >
                    <span class="nav-label">Special Sections</span>
                </a></li><li>
                <a class="nav-link  tnt-section-online-print-ads"  href="http://marketplace.rocketminer.com"  target="_blank" rel="noopener">
                    <span class="nav-label">Online Print Ads</span>
                </a></li></ul></div></div>
    <div id="topbar-col-two" class="col-md-6 col-sm-6"><div id="tncms-region-topbar-col-two" class="tncms-region "><div id="tncms-block-1305571" class="tncms-block"><div id="user-controls-1305571" class="user-controls show-onload clearfix pull-right"><div class="not-logged-in">
        <ul class="list-inline"><li><a href="https://www.rocketminer.com/users/signup/?referer_url=https%3A%2F%2Fwww.rocketminer.com%2Fopinion%2Fcolumnists%2Fdear-abby-for-july%2Farticle_d72b5be0-8023-593f-b2bb-c3de57fe9957.html" class="btn btn-link btn-sm user-control-link" rel="nofollow">Sign Up</a></li><li>
                    <a href="https://www.rocketminer.com/users/login/?referer_url=https%3A%2F%2Fwww.rocketminer.com%2Fopinion%2Fcolumnists%2Fdear-abby-for-july%2Farticle_d72b5be0-8023-593f-b2bb-c3de57fe9957.html" class="btn btn-primary btn-sm login-btn user-control-link" rel="nofollow">
                        Log In
                    </a></li>
        </ul>
    </div>

    <div class="logged-in">
        
        
            <div class="hide show-offcanvas">
                <ul class="list-inline">
                    <li><a href="https://www.rocketminer.com/users/admin/" class="btn btn-primary btn-sm login-btn user-control-link">Dashboard</a></li>
                    <li> <a class="btn btn-link btn-sm user-control-link" onclick="jQuery('#user-logout-form-1305571').submit(); return false;" rel="nofollow"> Logout</a></li>
                </ul>
            </div>
        
        <ul class="hide-offcanvas list-inline">
            <li class="dropdown pull-right">
                
                <div class="dropdown-toggle btn btn-link btn-sm user-dropdown" data-toggle="dropdown" data-hover="dropdown" data-hover-delay="250"><div class="tn-user-avatar pull-left"><!-- user avatar --></div><span class="tn-user-screenname pull-left"></span><b class="caret user-control-link"></b>
                </div>
                <ul class="dropdown-menu dropdown-menu-right" role="menu">
                    <li role="presentation" class="dropdown-header">My Account</li>
                    <li><a href="https://www.rocketminer.com/users/admin/" rel="nofollow"><i class="fas tnt-tachometer-alt tnt-fw"></i> Dashboard</a></li>
                    <li><a class="tn-user-profile-url" href="" data-app="https://www.rocketminer.com/users/"><i class="fas tnt-user tnt-fw"></i> Profile</a></li>
                    <li><a href="https://www.rocketminer.com/users/admin/list/" rel="nofollow"><i class="fas tnt-bookmark tnt-fw"></i> Saved items</a></li>
                    <li role="presentation" class="divider"></li>
                    <li><a class="logout-btn" onclick="jQuery('#user-logout-form-1305571').submit(); return false;" rel="nofollow"><i class="fas tnt-power-off tnt-fw"></i> Logout</a></li>
                </ul>
            </li>
        </ul>
    </div>
</div>

<form method="post" action="https://www.rocketminer.com/users/logout/" id="user-logout-form-1305571"><input type="hidden" name="referer_url" value="https://www.rocketminer.com/opinion/columnists/dear-abby-for-july/article_d72b5be0-8023-593f-b2bb-c3de57fe9957.html"><input type="submit" name="logout" value="Logout" class="hide">
</form></div><div id="tncms-block-1305569" class="tncms-block"><div class="follow-links-1305569 pull-right">
    
    <section id="block-1305569" class="block emphasis-h3   " ><ul class="list-inline">
        
            <li>
                <a href="https://www.facebook.com/rocketminernewspaper/" title="Facebook" target="_blank" rel="noopener" class="btn btn-xs btn-link fb" data-toggle="tooltip" data-placement="bottom">
                    <i class="fab tnt-facebook-f"></i>
                    <span class="sr-only">Facebook</span>
                </a>
            </li>
        
        
            <li>
                <a href="http://twitter.com/Rocket_Miner/" title="Twitter" target="_blank" rel="noopener" class="btn btn-xs btn-link tw" data-toggle="tooltip" data-placement="bottom">
                    <i class="fab tnt-twitter"></i>
                    <span class="sr-only">Twitter</span>
                </a>
            </li>
        
        
        
            <li>
                <a href="https://www.youtube.com/channel/UCkIJ3w8D5mYUsoC_nIKJyBQ" title="Youtube" target="_blank" rel="noopener" class="btn btn-xs btn-link yt" data-toggle="tooltip" data-placement="bottom">
                    <i class="fab tnt-youtube"></i>
                    <span class="sr-only">YouTube</span>
                </a>
            </li>
        
        
        
        
        
        
        
        
        
        
        
        
        
        
    </ul>
    </section>
</div>
<script type="application/ld+json">
{ "@context" : "https://schema.org",
  "@type" : "Organization",
  "url" : "http://www.rocketminer.com",
  "sameAs" : ["https://www.facebook.com/rocketminernewspaper/","http://twitter.com/Rocket_Miner/","https://www.youtube.com/channel/UCkIJ3w8D5mYUsoC_nIKJyBQ"]
}
</script>
<div class="clearfix"></div></div></div></div>
                </div>
            </header>
        </div>
    

    
        <div id="site-header-container" class="hidden-sm hidden-xs hidden-print">
            <header id="site-header" class="container" role="banner">
                
                <div class="row">
                    <div id="masthead-full-top" class="col-lg-12"><div id="tncms-region-masthead-full-top" class="tncms-region "></div></div>
                </div>
                <div class="row">
                    
                    <div id="masthead-col-one" class="col-md-4 col-sm-4"><div id="tncms-region-masthead-col-one" class="tncms-region "><div id="tncms-block-1305491" class="tncms-block a"><section id="block-1305491" class="block emphasis-h3   " ><div class="block"><a href="/" rel="nofollow" ><img 
            
            src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAQAAAADCAQAAAAe/WZNAAAAEElEQVR42mM8U88ABowYDABAxQPltt5zqAAAAABJRU5ErkJggg==" 
            data-srcset="https://bloximages.chicago2.vip.townnews.com/rocketminer.com/content/tncms/custom/image/fc25401a-956a-11e6-9a18-0326f0572d42.jpg?resize=200%2C23 200w, https://bloximages.chicago2.vip.townnews.com/rocketminer.com/content/tncms/custom/image/fc25401a-956a-11e6-9a18-0326f0572d42.jpg?resize=300%2C35 300w, https://bloximages.chicago2.vip.townnews.com/rocketminer.com/content/tncms/custom/image/fc25401a-956a-11e6-9a18-0326f0572d42.jpg?resize=400%2C47 400w, https://bloximages.chicago2.vip.townnews.com/rocketminer.com/content/tncms/custom/image/fc25401a-956a-11e6-9a18-0326f0572d42.jpg?resize=540%2C63 540w, https://bloximages.chicago2.vip.townnews.com/rocketminer.com/content/tncms/custom/image/fc25401a-956a-11e6-9a18-0326f0572d42.jpg?resize=750%2C88 750w, https://bloximages.chicago2.vip.townnews.com/rocketminer.com/content/tncms/custom/image/fc25401a-956a-11e6-9a18-0326f0572d42.jpg?resize=1200%2C140 1200w, https://bloximages.chicago2.vip.townnews.com/rocketminer.com/content/tncms/custom/image/fc25401a-956a-11e6-9a18-0326f0572d42.jpg?resize=1700%2C199 1700w" 
            data-sizes="auto" 
            class=" img-responsive lazyload tnt-prop-img"
            alt=""></a></div></section></div></div></div>
    <div id="masthead-col-two" class="col-md-4 col-sm-4"><div id="tncms-region-masthead-col-two" class="tncms-region "><div id="tncms-block-1305573" class="tncms-block"><div id="weather-1305573" class="weather-current size-medium pull-right">
    <ul class="list-unstyled">
        <li class="current-conditions dropdown">
            <a href="/weather/?weather_zip=82901" class="dropdown-toggle" data-toggle="dropdown" data-hover="dropdown" data-hover-delay="250">
                <span class="icon pull-left">
                    
                    <span class="fas tnt-wi-night-clear"></span>
                </span>
                <span class="pull-left temp-desc medium">
                    <span class="temp">79&deg;</span>
                    
                        <span class="cond">Fair <i class="fas tnt-caret-down"></i></span>
                    
                </span>
                <span class="clearfix"></span>
            </a>
            
                <ul class="dropdown-menu" role="menu">
                    <li>
                        <div class="weather-expanded">
                            <form action="/weather/" class="zip-update-form form-inline" method="get">
                                <input type="text" class="zip-update form-control" name="weather_zip" title="Weather ZIP Code" value="82901"> <input class="btn btn-primary" type="submit" value="GO">
                            </form>

                            <a href="javascript:;" class="pull-right zip-update-link" aria-label="weather_zip_toggle" onclick="jQuery('#weather-1305573 .zip-update-form').toggle('fast'); return false;"><span class="fas tnt-cog"></span></a>

                            <h4 class="city-title"><i class="fas tnt-map-marker-alt"></i>
                                
                                    Rock Springs, WY
                                
                                 <small>(82901)</small>
                            </h4>
                            <h5>Today</h5>
                            <p>Partly cloudy skies. Low 59F. Winds ENE at 10 to 20 mph..</p>
                            <h5>Tonight</h5>
                            <p>Partly cloudy skies. Low 59F. Winds ENE at 10 to 20 mph.</p>
                            <p class="text-center"><small><i class="fas tnt-info-circle"></i> Updated: July 21, 2019 @ 9:05 pm</small></p>
                        </div>
                    </li>
                    <li role="presentation" class="divider"></li>
                    <li class="forecast-link text-center"><a href="/weather/?weather_zip=82901"><i class="fas tnt-caret-right"></i> Full Forecast</a></li>
                </ul>
            
        </li>
    </ul>
</div>

    <div class="clearfix"></div>
</div></div></div>
    <div id="masthead-col-three" class="col-md-4 col-sm-4"><div id="tncms-region-masthead-col-three" class="tncms-region "><div id="tncms-block-1305567" class="tncms-block"><section id="block-1305567" class="block emphasis-h3   " >
    <div class="clearfix"></div>
    <div id="search-form-1305567" class="search-form-container card clearfix text-center ">
    <form id="site-search-1305567" action="/search/" method="GET" >
    <input type="hidden" name="sd" value="desc">
    <input type="hidden" name="l" value="25">
    
        
        <input type="hidden" name="sort" value="relevance">
    
    
    
    <input type="hidden" name="f" value="html">
    <input type="hidden" name="t" value="article,video,youtube,collection">
    <input type="hidden" name="app" value="editorial">
    <input type="hidden" name="nsa" value="eedition">
    <div class="site-search-form input-group pull-right normal form-control">
        <input id="site-search-1305567-term" name="q" title="Site Search" type="text" placeholder="Search..." class="form-control" autocomplete="off">
        <input type="submit" class="hide" value="Search">
        <span class="input-group-btn">
            <button id="site-search-1305567-btn" class="btn btn-link" aria-label="Submit Site Search" type="submit">
                
            </button>
        </span>
    </div>
    <div class="clearfix"></div>
</form>
        
        
        <div class="clearfix"></div>
    </div>
    </section> 

<script>
    $('#site-search-1305567-btn').on(__tnt.client.clickEvent, function(){
        $('#site-search-1305567').submit();
        return false;
    });

    $('#site-search-1305567').on('submit', function(){
        // Filter query
        var sQueryFiltered = $("#site-search-1305567 input[name=q]").val().replace(/\?/g, '');
    $("#site-search-1305567 input[name=q]").val( sQueryFiltered );

        if( $('#site-search-1305567-term').val() ){
            return true;
        }else{
            return false;
        }
    });</script></div></div></div>
                </div>
                <div class="row">
                    <div id="masthead-full-bottom" class="col-lg-12"><div id="tncms-region-masthead-full-bottom" class="tncms-region "></div></div>
                </div>
                
            </header>
        </div>
    

    
        <div id="site-navbar-container" class="hidden-print affix-top">
            
            <nav id="main-navigation" class="navbar yamm navbar-default container navbar-static">
                
                <div class="navbar-header">
                    
                    
                    
                        <button type="button" class="visible-sm visible-xs navbar-toggle pull-right" data-toggle="offcanvas" data-target="right">
                            <span class="sr-only">Toggle navigation</span>
                            <span class="icon-bar"></span>
                            <span class="icon-bar"></span>
                            <span class="icon-bar"></span>
                        </button>
                    

                    
                        <div class="navbar-brand hidden-md hidden-lg pos_right">
                            
                                <div id="tncms-region-main-nav-brand" class="tncms-region "><div id="tncms-block-1305564" class="tncms-block"><section id="block-1305564" class="block emphasis-h3   " ><div class="block"><a href="/" rel="nofollow" ><img 
            
            src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAQAAAADCAQAAAAe/WZNAAAAEElEQVR42mM8U88ABowYDABAxQPltt5zqAAAAABJRU5ErkJggg==" 
            data-srcset="https://bloximages.chicago2.vip.townnews.com/rocketminer.com/content/tncms/custom/image/f2209010-956a-11e6-9070-c3ed711c1b48.jpg?resize=200%2C23 200w, https://bloximages.chicago2.vip.townnews.com/rocketminer.com/content/tncms/custom/image/f2209010-956a-11e6-9070-c3ed711c1b48.jpg?resize=300%2C35 300w, https://bloximages.chicago2.vip.townnews.com/rocketminer.com/content/tncms/custom/image/f2209010-956a-11e6-9070-c3ed711c1b48.jpg?resize=400%2C47 400w, https://bloximages.chicago2.vip.townnews.com/rocketminer.com/content/tncms/custom/image/f2209010-956a-11e6-9070-c3ed711c1b48.jpg?resize=540%2C63 540w, https://bloximages.chicago2.vip.townnews.com/rocketminer.com/content/tncms/custom/image/f2209010-956a-11e6-9070-c3ed711c1b48.jpg?resize=750%2C88 750w, https://bloximages.chicago2.vip.townnews.com/rocketminer.com/content/tncms/custom/image/f2209010-956a-11e6-9070-c3ed711c1b48.jpg?resize=1200%2C140 1200w, https://bloximages.chicago2.vip.townnews.com/rocketminer.com/content/tncms/custom/image/f2209010-956a-11e6-9070-c3ed711c1b48.jpg?resize=1700%2C199 1700w" 
            data-sizes="auto" 
            class=" img-responsive lazyload tnt-prop-img"
            alt=""></a></div></section></div></div>
                            
                        </div>
                    

                    
                </div>

                
                    <div id="navbar-collapse" class="navbar-collapse collapse">
                        
                            <div class="pull-right">
                                <div id="tncms-region-main-nav-right-region" class="tncms-region "></div>
                                
                            </div>
                        
                        <div class="navbar-left">
                            <div id="tncms-region-nav-main-nav" class="tncms-region-nav"><ul id="main-nav_menu" class="nav navbar-nav"><li class="dropdown">
                <a class="nav-link nav-home dropdown-toggle  tnt-section-home"  data-toggle="dropdown" data-target="#" data-hover="dropdown" data-hover-delay="250"  href="/" >
                    <span class="nav-icon fas tnt-home tnt-fw"></span> <span class="nav-label">Home</span>
                </a><ul id="main-nav_menu-child-1" class="dropdown-menu"><li>
                <a class="nav-link  tnt-section-about-us"  href="/site/about.html" >
                    <span class="nav-label">About Us</span>
                </a></li><li>
                <a class="nav-link  tnt-section-contact-us"  href="/site/contact.html" >
                    <span class="nav-label">Contact Us</span>
                </a></li><li>
                <a class="nav-link  tnt-section-subscribe"  href="/site/forms/subscription_services/" >
                    <span class="nav-label">Subscribe</span>
                </a></li><li>
                <a class="nav-link  tnt-section-e-edition"  href="/eedition/" >
                    <span class="nav-label">e-Edition</span>
                </a></li><li class="dropdown">
                <a class="nav-link dropdown-toggle  tnt-section-partner-papers"  data-toggle="dropdown" data-target="#" data-nested="menu"    >
                    
                        <span class=""></span>
                    <span class="nav-label">Partner Papers</span>
                </a><ul id="main-nav_menu-child-1-child-5" class="dropdown-menu"><li>
                <a class="nav-link  tnt-section-wyoming-tribune-eagle"  href="http://www.wyomingnews.com/"  target="_blank" rel="noopener">
                    <span class="nav-label">Wyoming Tribune Eagle</span>
                </a></li><li>
                <a class="nav-link  tnt-section-laramie-boomerang"  href="http://www.laramieboomerang.com/"  target="_blank" rel="noopener">
                    <span class="nav-label">Laramie Boomerang</span>
                </a></li><li>
                <a class="nav-link  tnt-section-rawlins-daily-times"  href="http://www.rawlinstimes.com/"  target="_blank" rel="noopener">
                    <span class="nav-label">Rawlins Daily Times</span>
                </a></li><li>
                <a class="nav-link  tnt-section-wyoming-business-report"  href="http://www.wyomingbusinessreport.com"  target="_blank" rel="noopener">
                    <span class="nav-label">Wyoming Business Report</span>
                </a></li></ul></li><li class="dropdown">
                <a class="nav-link dropdown-toggle  tnt-section-employment"  data-toggle="dropdown" data-target="#" data-nested="menu"    >
                    
                        <span class=""></span>
                    <span class="nav-label">Employment</span>
                </a><ul id="main-nav_menu-child-1-child-6" class="dropdown-menu"><li>
                <a class="nav-link  tnt-section-employment-inquiry-form"  href="https://www.rocketminer.com/site/forms/online_services/employment_inquiry_form/"  target="_blank" rel="noopener">
                    <span class="nav-label">Employment Inquiry Form</span>
                </a></li></ul></li><li>
                <a class="nav-link  tnt-section-faq"  href="/site/faq.html" >
                    <span class="nav-label">FAQ</span>
                </a></li></ul></li><li class="dropdown">
                <a class="nav-link dropdown-toggle  tnt-section-news"  data-toggle="dropdown" data-target="#" data-hover="dropdown" data-hover-delay="250"  href="/news/" >
                    <span class="nav-label">News</span>
                </a><ul id="main-nav_menu-child-2" class="dropdown-menu"><li>
                <a class="nav-link  tnt-section-local-news"  href="/news/local/" >
                    <span class="nav-label">Local News</span>
                </a></li><li>
                <a class="nav-link  tnt-section-national"  href="/news/national/" >
                    <span class="nav-label">National</span>
                </a></li><li>
                <a class="nav-link  tnt-section-world"  href="/news/world/" >
                    <span class="nav-label">World</span>
                </a></li><li>
                <a class="nav-link  tnt-section-state"  href="/news/state/" >
                    <span class="nav-label">State</span>
                </a></li><li>
                <a class="nav-link  tnt-section-elections"  href="/elections/" >
                    <span class="nav-label">Elections</span>
                </a></li><li>
                <a class="nav-link  tnt-section-photo-galleries"  href="/multimedia/photo_galleries" >
                    <span class="nav-label">Photo Galleries</span>
                </a></li><li>
                <a class="nav-link  tnt-section-special-sections"  href="/special/" >
                    <span class="nav-label">Special Sections</span>
                </a></li><li>
                <a class="nav-link  tnt-section-submit-your-news"  href="http://rocketminer.com/users/admin/contribute/article/"  target="_blank" rel="noopener">
                    <span class="nav-label">Submit Your News</span>
                </a></li></ul></li><li class="dropdown">
                <a class="nav-link dropdown-toggle  tnt-section-sports"  data-toggle="dropdown" data-target="#" data-hover="dropdown" data-hover-delay="250"  href="/sports/" >
                    <span class="nav-label">Sports</span>
                </a><ul id="main-nav_menu-child-3" class="dropdown-menu"><li>
                <a class="nav-link  tnt-section-high-schools"  href="/sports/high_schools/" >
                    <span class="nav-label">High Schools</span>
                </a></li><li>
                <a class="nav-link  tnt-section-western-wyoming-cc"  href="/sports/western_wyoming_cc/" >
                    <span class="nav-label">Western Wyoming CC</span>
                </a></li><li>
                <a class="nav-link  tnt-section-university-of-wyoming"  href="/sports/university_of_wyoming/" >
                    <span class="nav-label">University of Wyoming</span>
                </a></li><li>
                <a class="nav-link  tnt-section-community-sports"  href="/sports/community_sports/" >
                    <span class="nav-label">Community Sports</span>
                </a></li><li>
                <a class="nav-link  tnt-section-rodeo"  href="/sports/rodeo" >
                    <span class="nav-label">Rodeo</span>
                </a></li></ul></li><li class="dropdown">
                <a class="nav-link dropdown-toggle  tnt-section-opinion"  data-toggle="dropdown" data-target="#" data-hover="dropdown" data-hover-delay="250"  href="/opinion/" >
                    <span class="nav-label">Opinion</span>
                </a><ul id="main-nav_menu-child-4" class="dropdown-menu"><li>
                <a class="nav-link  tnt-section-editorials"  href="/opinion/editorials/" >
                    <span class="nav-label">Editorials</span>
                </a></li><li>
                <a class="nav-link  tnt-section-letters-to-the-editor"  href="/opinion/letters_to_editor/" >
                    <span class="nav-label">Letters to the Editor</span>
                </a></li><li>
                <a class="nav-link  tnt-section-columnists"  href="/opinion/columnists/" >
                    <span class="nav-label">Columnists</span>
                </a></li><li>
                <a class="nav-link  tnt-section-cartoons"  href="/opinion/cartoons/" >
                    <span class="nav-label">Cartoons</span>
                </a></li></ul></li><li class="dropdown">
                <a class="nav-link dropdown-toggle  tnt-section-community"  data-toggle="dropdown" data-target="#" data-hover="dropdown" data-hover-delay="250"  href="/community/" >
                    <span class="nav-label">Community</span>
                </a><ul id="main-nav_menu-child-5" class="dropdown-menu"><li class="dropdown">
                <a class="nav-link dropdown-toggle  tnt-section-calendar"  data-toggle="dropdown" data-target="#" data-nested="menu"   href="/calendar/" >
                    
                        <span class=""></span>
                    <span class="nav-label">Calendar</span>
                </a><ul id="main-nav_menu-child-5-child-1" class="dropdown-menu"><li>
                <a class="nav-link  tnt-section-submit-your-event"  href="http://rocketminer.com/users/admin/calendar/event/"  target="_blank" rel="noopener">
                    <span class="nav-label">Submit Your Event</span>
                </a></li></ul></li><li>
                <a class="nav-link  tnt-section-club-newsgames"  href="/community/club_news_games/" >
                    <span class="nav-label">Club News/Games</span>
                </a></li><li>
                <a class="nav-link  tnt-section-people"  href="/community/people/" >
                    <span class="nav-label">People</span>
                </a></li><li class="dropdown">
                <a class="nav-link dropdown-toggle  tnt-section-entertainment"  data-toggle="dropdown" data-target="#" data-nested="menu"   href="/community/entertainment/" >
                    
                        <span class=""></span>
                    <span class="nav-label">Entertainment</span>
                </a><ul id="main-nav_menu-child-5-child-4" class="dropdown-menu"><li>
                <a class="nav-link  tnt-section-tv-listings"  href="/tv_listings/" >
                    <span class="nav-label">TV Listings</span>
                </a></li></ul></li><li>
                <a class="nav-link  tnt-section-your-take"  href="/community/your_take/" >
                    <span class="nav-label">Your Take</span>
                </a></li><li>
                <a class="nav-link  tnt-section-senior-menus"  href="/community/senior_menus/" >
                    <span class="nav-label">Senior Menus</span>
                </a></li><li>
                <a class="nav-link  tnt-section-school-menus"  href="/community/school_menus/" >
                    <span class="nav-label">School Menus</span>
                </a></li><li>
                <a class="nav-link  tnt-section-hospital-menus"  href="/community/hospital_menus/" >
                    <span class="nav-label">Hospital menus</span>
                </a></li><li>
                <a class="nav-link  tnt-section-community-map"  href="http://map.rocketminer.com"  target="_blank" rel="noopener">
                    <span class="nav-label">Community Map</span>
                </a></li></ul></li><li class="dropdown">
                <a class="nav-link dropdown-toggle  tnt-section-milestones"  data-toggle="dropdown" data-target="#" data-hover="dropdown" data-hover-delay="250"   >
                    <span class="nav-label">Milestones</span>
                </a><ul id="main-nav_menu-child-6" class="dropdown-menu"><li class="dropdown">
                <a class="nav-link dropdown-toggle  tnt-section-submit-announcements"  data-toggle="dropdown" data-target="#" data-nested="menu"    >
                    
                        <span class=""></span>
                    <span class="nav-label">Submit Announcements</span>
                </a><ul id="main-nav_menu-child-6-child-1" class="dropdown-menu"><li>
                <a class="nav-link  tnt-section-tiny-tots"  href="/site/forms/announcements/tiny_tots/" >
                    <span class="nav-label">Tiny Tots</span>
                </a></li><li>
                <a class="nav-link  tnt-section-engagements"  href="/site/forms/announcements/engagement_announcement/" >
                    <span class="nav-label">Engagements</span>
                </a></li><li>
                <a class="nav-link  tnt-section-weddings"  href="/site/forms/announcements/wedding_announcement/" >
                    <span class="nav-label">Weddings</span>
                </a></li><li>
                <a class="nav-link  tnt-section-anniversaries"  href="/site/forms/announcements/anniversary_announcement/" >
                    <span class="nav-label">Anniversaries</span>
                </a></li><li>
                <a class="nav-link  tnt-section-births"  href="/site/forms/announcements/birth_announcement/" >
                    <span class="nav-label">Births</span>
                </a></li><li>
                <a class="nav-link  tnt-section-obituaries"  href="/site/forms/online_services/obit/" >
                    <span class="nav-label">Obituaries</span>
                </a></li><li>
                <a class="nav-link  tnt-section-veterans"  href="mailto:editor@rocketminer.com" >
                    <span class="nav-label">Veterans</span>
                </a></li></ul></li><li class="dropdown">
                <a class="nav-link dropdown-toggle  tnt-section-view-announcements"  data-toggle="dropdown" data-target="#" data-nested="menu"    >
                    
                        <span class=""></span>
                    <span class="nav-label">View Announcements</span>
                </a><ul id="main-nav_menu-child-6-child-2" class="dropdown-menu"><li>
                <a class="nav-link  tnt-section-births"  href="/community/births" >
                    <span class="nav-label">Births</span>
                </a></li><li>
                <a class="nav-link  tnt-section-tiny-tots"  href="/community/tiny_tots/" >
                    <span class="nav-label">Tiny Tots</span>
                </a></li></ul></li></ul></li><li>
                <a class="nav-link  tnt-section-obituaries"  href="/obituaries/" >
                    <span class="nav-label">Obituaries</span>
                </a></li><li class="dropdown">
                <a class="nav-link dropdown-toggle  tnt-section-records"  data-toggle="dropdown" data-target="#" data-hover="dropdown" data-hover-delay="250"  href="/records/" >
                    <span class="nav-label">Records</span>
                </a><ul id="main-nav_menu-child-8" class="dropdown-menu"><li class="dropdown">
                <a class="nav-link dropdown-toggle  tnt-section-arrests"  data-toggle="dropdown" data-target="#" data-nested="menu"    >
                    
                        <span class=""></span>
                    <span class="nav-label">Arrests</span>
                </a><ul id="main-nav_menu-child-8-child-1" class="dropdown-menu"><li>
                <a class="nav-link  tnt-section-sweetwater-county-sheriffs-office"  href="/records/sweetwater_county_sheriffs_office/" >
                    <span class="nav-label">Sweetwater County Sheriff's Office</span>
                </a></li><li>
                <a class="nav-link  tnt-section-rock-springs-police"  href="/records/rock_springs_police/" >
                    <span class="nav-label">Rock Springs Police</span>
                </a></li><li>
                <a class="nav-link  tnt-section-green-river-police"  href="/records/green_river_police/" >
                    <span class="nav-label">Green River Police</span>
                </a></li></ul></li><li>
                <a class="nav-link  tnt-section-sex-offenders"  href="/records/sex_offenders/" >
                    <span class="nav-label">Sex Offenders</span>
                </a></li><li class="dropdown">
                <a class="nav-link dropdown-toggle  tnt-section-municipal-courts"  data-toggle="dropdown" data-target="#" data-nested="menu"    >
                    
                        <span class=""></span>
                    <span class="nav-label">Municipal Courts</span>
                </a><ul id="main-nav_menu-child-8-child-3" class="dropdown-menu"><li>
                <a class="nav-link  tnt-section-rock-springs-municipal-court"  href="/records/rock_springs_municipal_court/" >
                    <span class="nav-label">Rock Springs Municipal Court</span>
                </a></li><li>
                <a class="nav-link  tnt-section-green-river-municipal-court"  href="/records/green_river_municipal_court/" >
                    <span class="nav-label">Green River Municipal Court</span>
                </a></li></ul></li><li class="dropdown">
                <a class="nav-link dropdown-toggle  tnt-section-circuit-courts"  data-toggle="dropdown" data-target="#" data-nested="menu"    >
                    
                        <span class=""></span>
                    <span class="nav-label">Circuit Courts</span>
                </a><ul id="main-nav_menu-child-8-child-4" class="dropdown-menu"><li>
                <a class="nav-link  tnt-section-rock-springs-circuit-court"  href="/records/rock_springs_circuit_court/" >
                    <span class="nav-label">Rock Springs Circuit Court</span>
                </a></li><li>
                <a class="nav-link  tnt-section-green-river-circuit-court"  href="/records/green_river_circuit_court/" >
                    <span class="nav-label">Green River Circuit Court</span>
                </a></li></ul></li><li>
                <a class="nav-link  tnt-section-jail-roster"  href="https://sweetwater911.org/apps/jailroster/"  target="_blank" rel="noopener">
                    <span class="nav-label">Jail Roster</span>
                </a></li><li>
                <a class="nav-link  tnt-section-judgments"  href="/records/judgments/" >
                    <span class="nav-label">Judgments</span>
                </a></li><li>
                <a class="nav-link  tnt-section-marriages"  href="/records/marriages/" >
                    <span class="nav-label">Marriages</span>
                </a></li><li>
                <a class="nav-link  tnt-section-divorces"  href="/records/divorces/" >
                    <span class="nav-label">Divorces</span>
                </a></li><li>
                <a class="nav-link  tnt-section-warranty-deeds"  href="/records/warranty_deeds/" >
                    <span class="nav-label">Warranty Deeds</span>
                </a></li><li>
                <a class="nav-link  tnt-section-valuation_reports"  href="/records/valuation_reports/" >
                    <span class="nav-label">Valuation_reports</span>
                </a></li></ul></li><li class="dropdown">
                <a class="nav-link dropdown-toggle  tnt-section-classifieds"  data-toggle="dropdown" data-target="#" data-hover="dropdown" data-hover-delay="250"   >
                    <span class="nav-label">Classifieds</span>
                </a><ul id="main-nav_menu-child-9" class="dropdown-menu"><li>
                <a class="nav-link  tnt-section-view-classifieds"  href="/classifieds/" >
                    <span class="nav-label">View Classifieds</span>
                </a></li><li>
                <a class="nav-link  tnt-section-view-legals"  href="http://www.rocketminer.com/classifieds/service/legal/"  target="_blank" rel="noopener">
                    <span class="nav-label">View Legals</span>
                </a></li><li>
                <a class="nav-link  tnt-section-place-an-ad"  href="https://classadz.vdata.com/RockSpringsRocketMiner/Advertising/Advertiser"  target="_blank" rel="noopener">
                    <span class="nav-label">Place an Ad</span>
                </a></li></ul></li><li>
                <a class="nav-link  tnt-section-weather"  href="/weather/" >
                    <span class="nav-label">Weather</span>
                </a></li></ul></div>
                        </div>
                    </div>
                

                
            </nav>
            
            
        </div>
        
            
        
    
    <div id="main-body-container">
    <section id="main-top-container" class="container-fullscreen-region container-fluid">
        
        <div class="fullscreen-region"><div id="tncms-region-global-container-top-fullscreen" class="tncms-region "><div id="tncms-block-1328620" class="tncms-block"><style>
.faq_alert2 {
padding: 20px 0px 20px 0px;
    background-color: #ffeeee;
    box-shadow: 10px 10px 5px #888888;
    text-align:center;
    margin-bottom:20px;
}

</style><h4 class="faq_alert2">Having trouble with logging in or registering on the new system? <a href="http://www.rocketminer.com/site/faq.html">Click here</a>
</h4></div></div></div>
    </section>
    <section id="main-page-container" class="container">
        <div class="row">
                <div id="asset-container-top" class="col-md-12"><div id="tncms-region-asset_container_top" class="tncms-region hidden-print"></div></div>
            
            <div class="col-md-12"><div id="tncms-region-global-container-top" class="tncms-region "><div id="tncms-block-1305432" class="tncms-block hidden-xs"><script type="text/javascript">
TNCMS.AdManager.init
({
  domain: "www.rocketminer.com",
  secureDomain: "www.rocketminer.com",
  virtualregion: {
            popup: __tnt.ads.popup
        },
  callback: {
            expandable: __tnt.ads.expandable,
            html: __tnt.ads.html,
            image: __tnt.ads.image,
            pagecurl: __tnt.ads.curl,
            text: __tnt.ads.text,
            video: __tnt.ads.video
        }
});
</script>

        <div id="blox-ad-position-leaderboard-top1" data-tnt-ads='{"vendor":"blox","type":"position","display":"default","region":"leaderboard-top","slot":"1","fold":"above","width":"728","js":{"video":"https:\/\/bloximages.chicago2.vip.townnews.com\/rocketminer.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/video\/resources\/scripts\/video.512a6903eae08e033c76afdce2a0eac7.js"},"overline":"","refresh":false}' class="blox-ad tnt-ads-container ">
        
        </div></div><div id="tncms-block-1305433" class="tncms-block visible-xs">
        <div id="blox-ad-position-block-leaderboard-top-mobile1" data-tnt-ads='{"vendor":"blox","type":"position","display":"default","region":"block-leaderboard-top-mobile","slot":"1","fold":"above","width":"320","js":{"video":"https:\/\/bloximages.chicago2.vip.townnews.com\/rocketminer.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/video\/resources\/scripts\/video.512a6903eae08e033c76afdce2a0eac7.js"},"overline":"","refresh":false}' class="blox-ad tnt-ads-container ">
        
        </div></div></div></div>
        </div><article itemscope itemtype="https://schema.org/Article" id="asset-d72b5be0-8023-593f-b2bb-c3de57fe9957" class="asset article-default"  data-url="https://www.rocketminer.com/opinion/columnists/dear-abby-for-july/article_d72b5be0-8023-593f-b2bb-c3de57fe9957.html">
    <span itemscope itemtype="http://schema.org/SpeakableSpecification">
        <meta itemprop="cssSelector" content=".asset-header .headline" />
        <meta itemprop="cssSelector" content=".asset-content p:first-of-type" />
    </span><div itemprop="publisher" itemscope itemtype="https://schema.org/Organization">
        <div itemprop="logo" itemscope itemtype="https://schema.org/ImageObject">
            <meta itemprop="url" content="https://bloximages.chicago2.vip.townnews.com/rocketminer.com/content/tncms/custom/image/0be4b2fa-ee45-11e6-8d25-fb5ddfaadb65.jpg">
            <meta itemprop="width" content="979">
            <meta itemprop="height" content="979">
        </div>
        <meta itemprop="name" content="rocketminer.com">
    </div>
    <link itemprop="mainEntityOfPage" href="https://www.rocketminer.com/opinion/columnists/dear-abby-for-july/article_d72b5be0-8023-593f-b2bb-c3de57fe9957.html" />
    <style>
                .asset-paging .direction {
                    color: #ae501b;
                }
            </style><div class="asset-paging-container hidden-print">
            <div id="asset-paging-d72b5be0-8023-593f-b2bb-c3de57fe9957" class="asset-paging">
                <div id="paging-prev-d72b5be0-8023-593f-b2bb-c3de57fe9957" class="paging-link prev offset"></div>
                <div id="paging-next-d72b5be0-8023-593f-b2bb-c3de57fe9957" class="paging-link next offset"></div>
                <div class="clearfix"></div>
            </div>
        </div>
        <script>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</script><div class="asset-masthead ">
        <header class="asset-header">
    
        <div class="asset-label-flags">
            <span class="tnt-flag label label-flag label-flag-default label-flag-web-only">web only</span> 
        </div>
    
    <h1 itemprop="headline" class="headline">
        <span>
            
            Dear Abby for July 22, 2019
        </span>
    </h1>
    
    <div class="meta">
        <span>
            <ul class="list-inline">
        
        
            <li>
        <time datetime="2019-07-21T19:00:00-06:00" class="tnt-date asset-date text-muted">2 hrs ago</time></li>
        
        
            <li class="hidden-print"><a href="/opinion/columnists/dear-abby-for-july/article_d72b5be0-8023-593f-b2bb-c3de57fe9957.html#comments" class="cm" title="0 comments"><span class="fas tnt-comments"></span> <span class="count">0</span></a></li>
        
        
    </ul>
        </span>
    </div>
    <meta itemprop="dateCreated" content="2019-07-21T19:00:00-06:00">
    <meta itemprop="datePublished" content="2019-07-21T19:00:00-06:00">
    <meta itemprop="dateModified" content="2019-07-21T19:00:00-06:00">
</header>
        
        
            <div class="share-container headline-right pull-right hidden-xs" data-subscription-required-remove><ul class="social-share-links hidden-print list-unstyled stacked icon">
        <li class="social-share-link fb">
        <a href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fwww.rocketminer.com%2Fopinion%2Fcolumnists%2Fdear-abby-for-july%2Farticle_d72b5be0-8023-593f-b2bb-c3de57fe9957.html%3Futm_medium%3Dsocial%26utm_source%3Dfacebook%26utm_campaign%3Duser-share" class="tnt-share-link fb" target="_blank" rel="noopener nofollow" title="Share on Facebook"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Facebook","socialAction":"post","url":"/opinion/columnists/dear-abby-for-july/article_d72b5be0-8023-593f-b2bb-c3de57fe9957.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":d72b5be0-8023-593f-b2bb-c3de57fe9957}' >    
                <span class="tnt-stack" data-toggle="tooltip" data-placement="left" title="Share">
                    
                    <i class="fab tnt-facebook-f tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Facebook</span>
            </a>
        </li><li class="social-share-link tw">
            <a href="https://twitter.com/intent/tweet?&text=Dear%20Abby%20for%20July%2022%2C%202019&via=Rocket_Miner&url=https%3A%2F%2Fwww.rocketminer.com%2Fopinion%2Fcolumnists%2Fdear-abby-for-july%2Farticle_d72b5be0-8023-593f-b2bb-c3de57fe9957.html%3Futm_medium%3Dsocial%26utm_source%3Dtwitter%26utm_campaign%3Duser-share" class="tnt-share-link tw" target="_blank" rel="noopener nofollow" title="Tweet"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Twitter","socialAction":"tweet","url":"/opinion/columnists/dear-abby-for-july/article_d72b5be0-8023-593f-b2bb-c3de57fe9957.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":d72b5be0-8023-593f-b2bb-c3de57fe9957}' >
                <span class="tnt-stack" data-toggle="tooltip" data-placement="left" title="Tweet">
                    
                    <i class="fab tnt-twitter tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Twitter</span>
            </a>
        </li><li class="social-share-link sms" style="display:none;">
            <a href="sms:?body=Check%20out%20this%20link:%20www.rocketminer.com/tncms/asset/editorial/d72b5be0-8023-593f-b2bb-c3de57fe9957" class="tnt-share-link sms" title="SMS" data-track='{"category":"tnt-sms","action":"share","label":"editorial-article","value":""}' data-tncms-track-event='{"app":"editorial","metric":"sms","uuid":d72b5be0-8023-593f-b2bb-c3de57fe9957}'  rel="nofollow">
                <span class="tnt-stack" data-toggle="tooltip" data-placement="left" title="SMS">
                    
                    <i class="fas tnt-comment-alt-dots tnt-stack-1x"></i>
                </span>
                <span class="sr-only">SMS</span>
            </a>
        </li><li class="social-share-link em">
            <a href="mailto:?subject=%5Brocketminer.com%5D%20Dear%20Abby%20for%20July%2022%2C%202019&body=https%3A%2F%2Fwww.rocketminer.com%2Fopinion%2Fcolumnists%2Fdear-abby-for-july%2Farticle_d72b5be0-8023-593f-b2bb-c3de57fe9957.html%3Futm_medium%3Dsocial%26utm_source%3Demail%26utm_campaign%3Duser-share" class="tnt-share-link em email-share-link" title="Email"  data-track='{"category":"tnt-email","action":"share","label":"editorial-article","value":""}' data-tncms-track-event='{"app":"editorial","metric":"email","uuid":d72b5be0-8023-593f-b2bb-c3de57fe9957}'  bSendHash rel="nofollow">
                <span class="tnt-stack" data-toggle="tooltip" data-placement="left" title="Email">
                    
                    <i class="fas tnt-envelope tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Email</span>
            </a>
        </li></ul></div>
        
    </div>

    

    <div class="row">
        <div class="main-content col-lg-8 col-md-7"><div class="main-content-wrap">
            <div id="tncms-region-article_top" class="tncms-region hidden-print"></div>
            
            

            

            

            <div id="tncms-region-article_top_content" class="tncms-region hidden-print"></div>

            <div id="asset-content" data-asset-uuid="d72b5be0-8023-593f-b2bb-c3de57fe9957">
                

                <div class="row">
                    <div class="col-lg-12 col-md-12 col-sm-12" data-subscription-required-class="col-xs-12">
                        
                        <div class="asset-body" data-subscription-required-class="asset-body">
                            
                                <div class="share-container content-above" data-subscription-required-remove><ul class="social-share-links hidden-print list-inline icon">
        <li class="social-share-link fb">
        <a href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fwww.rocketminer.com%2Fopinion%2Fcolumnists%2Fdear-abby-for-july%2Farticle_d72b5be0-8023-593f-b2bb-c3de57fe9957.html%3Futm_medium%3Dsocial%26utm_source%3Dfacebook%26utm_campaign%3Duser-share" class="tnt-share-link fb" target="_blank" rel="noopener nofollow" title="Share on Facebook"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Facebook","socialAction":"post","url":"/opinion/columnists/dear-abby-for-july/article_d72b5be0-8023-593f-b2bb-c3de57fe9957.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":d72b5be0-8023-593f-b2bb-c3de57fe9957}' >    
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-facebook-f tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Facebook</span>
            </a>
        </li><li class="social-share-link tw">
            <a href="https://twitter.com/intent/tweet?&text=Dear%20Abby%20for%20July%2022%2C%202019&via=Rocket_Miner&url=https%3A%2F%2Fwww.rocketminer.com%2Fopinion%2Fcolumnists%2Fdear-abby-for-july%2Farticle_d72b5be0-8023-593f-b2bb-c3de57fe9957.html%3Futm_medium%3Dsocial%26utm_source%3Dtwitter%26utm_campaign%3Duser-share" class="tnt-share-link tw" target="_blank" rel="noopener nofollow" title="Tweet"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Twitter","socialAction":"tweet","url":"/opinion/columnists/dear-abby-for-july/article_d72b5be0-8023-593f-b2bb-c3de57fe9957.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":d72b5be0-8023-593f-b2bb-c3de57fe9957}' >
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-twitter tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Twitter</span>
            </a>
        </li><li class="social-share-link sms" style="display:none;">
            <a href="sms:?body=Check%20out%20this%20link:%20www.rocketminer.com/tncms/asset/editorial/d72b5be0-8023-593f-b2bb-c3de57fe9957" class="tnt-share-link sms" title="SMS" data-track='{"category":"tnt-sms","action":"share","label":"editorial-article","value":""}' data-tncms-track-event='{"app":"editorial","metric":"sms","uuid":d72b5be0-8023-593f-b2bb-c3de57fe9957}'  rel="nofollow">
                <span class="tnt-stack" >
                    
                    <i class="fas tnt-comment-alt-dots tnt-stack-1x"></i>
                </span>
                <span class="sr-only">SMS</span>
            </a>
        </li><li class="social-share-link em">
            <a href="mailto:?subject=%5Brocketminer.com%5D%20Dear%20Abby%20for%20July%2022%2C%202019&body=https%3A%2F%2Fwww.rocketminer.com%2Fopinion%2Fcolumnists%2Fdear-abby-for-july%2Farticle_d72b5be0-8023-593f-b2bb-c3de57fe9957.html%3Futm_medium%3Dsocial%26utm_source%3Demail%26utm_campaign%3Duser-share" class="tnt-share-link em email-share-link" title="Email"  data-track='{"category":"tnt-email","action":"share","label":"editorial-article","value":""}' data-tncms-track-event='{"app":"editorial","metric":"email","uuid":d72b5be0-8023-593f-b2bb-c3de57fe9957}'  bSendHash rel="nofollow">
                <span class="tnt-stack" >
                    
                    <i class="fas tnt-envelope tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Email</span>
            </a>
        </li><li class="social-share-link pr">
                <a href="javascript:window.print()" class="pr" title="Print" data-track='{"network":"Print","socialAction":"print","url":"/opinion/columnists/dear-abby-for-july/article_d72b5be0-8023-593f-b2bb-c3de57fe9957.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":d72b5be0-8023-593f-b2bb-c3de57fe9957}'  rel="nofollow">
                    <span class="tnt-stack" >
                        
                        <i class="fas tnt-print tnt-stack-1x"></i>
                    </span>
                    <span class="sr-only">Print</span>
                </a>
            </li><li class="social-share-link sv">
        <a class="save-list-d72b5be0-8023-593f-b2bb-c3de57fe9957-btn save-asset " title="Save to list" href="#"  role="button" rel="nofollow" data-asset-uuid="d72b5be0-8023-593f-b2bb-c3de57fe9957" >
            
                <span class="tnt-stack">
                    
                    <i class="asset-save-icon far tnt-bookmark tnt-stack-1x "></i>
                </span>
            
            
                <span class="sr-only">Save</span>
            
        </a>
        </li>
        
    </ul><form method="post" data-uuid="d72b5be0-8023-593f-b2bb-c3de57fe9957" class="save-list-d72b5be0-8023-593f-b2bb-c3de57fe9957-form save-asset-to-list" action="/users/admin/list/">
        <input type="hidden" name="action" value="addasset" />
        <input type="hidden" name="format" value="json" />
        <input type="hidden" name="listasset" value="d72b5be0-8023-593f-b2bb-c3de57fe9957" />
        <input type="hidden" name="listapp" value="editorial" />
        <input type="hidden" name="autocreate" value="true" />
        <input type="hidden" name="listname" value="articles" />
        <input class="hide" type="submit" name="submit" value="Save" />
    </form>
</div>
                            <div id="tncms-region-article_body_top" class="tncms-region hidden-print"></div>

                            <div itemprop="articleBody" class="asset-content  subscriber-premium">
                                <meta itemprop="isAccessibleForFree" content="true"/>
                                
                                
                                <p><strong>DEAR ABBY</strong>: My boyfriend and I have been dating for nearly two years. He would literally do anything for me. He's incredibly affectionate and supportive, and a lot of women would love to have someone like him.</p><p>My problem is we see the world through completely different eyes. I'm an artist. I want to go out and explore the world and do crazy things. He's more comfortable at home with video games and he's not comfortable mingling with crowds. He can be overprotective sometimes, and when I bring up my concerns about possibly breaking up, he doesn't take me seriously and says, "You do this every time you're upset."</p><p>We live together and are dependent both financially and emotionally. Honestly, I would like to stay with him, but I'm torn about what to do. Should I leave someone I should be grateful for in order to chase selfish dreams? Or should I stay and encourage him to change? -- CHASING MY DREAMS</p><div id="tncms-region-article_instory_top" class="tncms-region hidden-print"></div><p><strong>DEAR CHASING YOUR DREAMS</strong>: Your boyfriend isn't going to change. If you can't accept him the way he is, then it would be better for both of you to separate.</p><p><strong>DEAR ABBY</strong>: I like to host parties for my kids, family events and game nights with friends. I love when my home is filled with loving family and friends. But when we open our home, there always seems to be someone who feels it necessary to point out something wrong with our home or something that should be fixed. It drives me nuts! I find it hard to respond without sounding snotty. When I'm invited to someone's home, I would never walk around and nitpick and point out problem areas. I would love it if you could give me examples of what I can say to deflect those not-so-helpful comments. -- HOST IN ILLINOIS</p><p><strong>DEAR HOST</strong>: Allow me to offer you a menu. Feel free to pick and choose as you please:</p><p>1. "Oh, my! I hadn't noticed."</p><p>2. "Thank you for pointing that out. I'll have it fixed before you come back over." (And don't invite the person again.)</p><div id="tncms-region-article_instory_middle" class="tncms-region hidden-print"></div><p>3. "The next time you visit, be sure to bring along your wrench."</p><p><strong>DEAR ABBY</strong>: For our anniversary, I bought my wife a $1,500 necklace and told her that if she wanted, it could be exchanged at the store within a month.</p><p>The following week she went out with some friends and came back with a different piece of jewelry from the store that cost an additional $800. Besides the financial aspect, I'm feeling hurt that what I gave was not adequate enough for her. Am I being too sensitive here? -- HURT FEELINGS IN BOCA RATON</p><p><strong>DEAR HURT FEELINGS</strong>: You are a generous and loving husband. You should not, however, feel hurt that your wife exchanged the necklace. You told her she could, and she took you up on it. Perhaps next time you should consider asking her what she would like, so you can choose the gift "together."</p><p><em>Dear Abby is written by Abigail Van Buren, also known as Jeanne Phillips, and was founded by her mother, Pauline Phillips. Contact Dear Abby at <a href="http://www.DearAbby.com">www.DearAbby.com</a> or P.O. Box 69440, Los Angeles, CA 90069.</em></p><div id="tncms-region-article_instory_bottom" class="tncms-region hidden-print"></div><div id="tncms-region-article_bottom_content" class="tncms-region hidden-print"></div>
                                
                            </div>
                            
                            

                            
    


                            
                                <div class="share-container content-below" data-subscription-required-remove><ul class="social-share-links hidden-print list-inline icon">
        <li class="social-share-link fb">
        <a href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fwww.rocketminer.com%2Fopinion%2Fcolumnists%2Fdear-abby-for-july%2Farticle_d72b5be0-8023-593f-b2bb-c3de57fe9957.html%3Futm_medium%3Dsocial%26utm_source%3Dfacebook%26utm_campaign%3Duser-share" class="tnt-share-link fb" target="_blank" rel="noopener nofollow" title="Share on Facebook"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Facebook","socialAction":"post","url":"/opinion/columnists/dear-abby-for-july/article_d72b5be0-8023-593f-b2bb-c3de57fe9957.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":d72b5be0-8023-593f-b2bb-c3de57fe9957}' >    
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-facebook-f tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Facebook</span>
            </a>
        </li><li class="social-share-link tw">
            <a href="https://twitter.com/intent/tweet?&text=Dear%20Abby%20for%20July%2022%2C%202019&via=Rocket_Miner&url=https%3A%2F%2Fwww.rocketminer.com%2Fopinion%2Fcolumnists%2Fdear-abby-for-july%2Farticle_d72b5be0-8023-593f-b2bb-c3de57fe9957.html%3Futm_medium%3Dsocial%26utm_source%3Dtwitter%26utm_campaign%3Duser-share" class="tnt-share-link tw" target="_blank" rel="noopener nofollow" title="Tweet"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Twitter","socialAction":"tweet","url":"/opinion/columnists/dear-abby-for-july/article_d72b5be0-8023-593f-b2bb-c3de57fe9957.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":d72b5be0-8023-593f-b2bb-c3de57fe9957}' >
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-twitter tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Twitter</span>
            </a>
        </li><li class="social-share-link sms" style="display:none;">
            <a href="sms:?body=Check%20out%20this%20link:%20www.rocketminer.com/tncms/asset/editorial/d72b5be0-8023-593f-b2bb-c3de57fe9957" class="tnt-share-link sms" title="SMS" data-track='{"category":"tnt-sms","action":"share","label":"editorial-article","value":""}' data-tncms-track-event='{"app":"editorial","metric":"sms","uuid":d72b5be0-8023-593f-b2bb-c3de57fe9957}'  rel="nofollow">
                <span class="tnt-stack" >
                    
                    <i class="fas tnt-comment-alt-dots tnt-stack-1x"></i>
                </span>
                <span class="sr-only">SMS</span>
            </a>
        </li><li class="social-share-link em">
            <a href="mailto:?subject=%5Brocketminer.com%5D%20Dear%20Abby%20for%20July%2022%2C%202019&body=https%3A%2F%2Fwww.rocketminer.com%2Fopinion%2Fcolumnists%2Fdear-abby-for-july%2Farticle_d72b5be0-8023-593f-b2bb-c3de57fe9957.html%3Futm_medium%3Dsocial%26utm_source%3Demail%26utm_campaign%3Duser-share" class="tnt-share-link em email-share-link" title="Email"  data-track='{"category":"tnt-email","action":"share","label":"editorial-article","value":""}' data-tncms-track-event='{"app":"editorial","metric":"email","uuid":d72b5be0-8023-593f-b2bb-c3de57fe9957}'  bSendHash rel="nofollow">
                <span class="tnt-stack" >
                    
                    <i class="fas tnt-envelope tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Email</span>
            </a>
        </li><li class="social-share-link pr">
                <a href="javascript:window.print()" class="pr" title="Print" data-track='{"network":"Print","socialAction":"print","url":"/opinion/columnists/dear-abby-for-july/article_d72b5be0-8023-593f-b2bb-c3de57fe9957.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":d72b5be0-8023-593f-b2bb-c3de57fe9957}'  rel="nofollow">
                    <span class="tnt-stack" >
                        
                        <i class="fas tnt-print tnt-stack-1x"></i>
                    </span>
                    <span class="sr-only">Print</span>
                </a>
            </li><li class="social-share-link sv">
        <a class="save-list-d72b5be0-8023-593f-b2bb-c3de57fe9957-btn save-asset " title="Save to list" href="#"  role="button" rel="nofollow" data-asset-uuid="d72b5be0-8023-593f-b2bb-c3de57fe9957" >
            
                <span class="tnt-stack">
                    
                    <i class="asset-save-icon far tnt-bookmark tnt-stack-1x "></i>
                </span>
            
            
                <span class="sr-only">Save</span>
            
        </a>
        </li>
        
    </ul><form method="post" data-uuid="d72b5be0-8023-593f-b2bb-c3de57fe9957" class="save-list-d72b5be0-8023-593f-b2bb-c3de57fe9957-form save-asset-to-list" action="/users/admin/list/">
        <input type="hidden" name="action" value="addasset" />
        <input type="hidden" name="format" value="json" />
        <input type="hidden" name="listasset" value="d72b5be0-8023-593f-b2bb-c3de57fe9957" />
        <input type="hidden" name="listapp" value="editorial" />
        <input type="hidden" name="autocreate" value="true" />
        <input type="hidden" name="listname" value="articles" />
        <input class="hide" type="submit" name="submit" value="Save" />
    </form>
</div>
                            
                        </div>
                        
                    </div></div><!-- /asset-content -->

                <div id="asset-below">
                    

                    

                    

                    

                    

                    

                    

                    

                    

                    

                    

                    <div id="tncms-region-article_bottom" class="tncms-region hidden-print"></div><div class="asset-recommend native-programmatic hidden-print">
    <script id="yap_id1">
        var adUnitCode = adUnitCode || [];
        adUnitCode.push("832ed22d-3ce2-4937-9f93-e56306b8315c");
        var apiKey = "YDC2G9T2K4BXNCJ3XDMR";
        (function () {
            var script = document.createElement("script");
            script.async = true;
            script.src = "https://s.yimg.com/av/yap/ga/yap.js";
            document.body.appendChild(script);
        })();
        var yap_script = document.getElementById('yap_id1');
        var yap_parent_node = yap_script.parentNode;
        var container_yap_div = document.createElement('div');
        container_yap_div.className = 'yap-ad-832ed22d-3ce2-4937-9f93-e56306b8315c';
        yap_parent_node.insertBefore(container_yap_div, yap_script);
    </script>
</div><div class="asset-recommend taboola hidden-print"><div id="taboola-video-outstream"></div><div id="taboola-below-article-thumbnails"></div><div id="taboola-below-article-text-links"></div></div>

                    <div class="asset-comments hidden-print">
<div id="commentPostModal" class="modal fade">
    <div class="modal-dialog">
        <div class="modal-content">
            <div class="modal-header">
                <button type="button" class="close" data-dismiss="modal" aria-hidden="true">&times;</button>
                <h4 class="heading modal-title">Post a comment<span class="not-logged-in"> as </span></h4>
            </div>

            <form method="post" action="/tncms/comment/post/" id="commentPost">
                <input type="hidden" name="action" value="comments:post" />
                <input type="hidden" name="id" value="d72b5be0-8023-593f-b2bb-c3de57fe9957" />
                <input type="hidden" name="app" value="editorial" />
                
                <div class="modal-body form-body">
                    
                    <div class="alert alert-info" style="display:none"></div>

                    

                    <a class="comment-emoticons-selector" data-toggle="collapse" data-target="#comment-emoticons-selector">Emoticons <span class="caret"></span></a>

                    <div id="comment-emoticons-selector" class="hidden-print collapse">
    <ul class="emoticon-selector list-unstyled list-inline">
        <li><a title="[smile]">[smile]</a></li>
        <li><a title="[beam]">[beam]</a></li>
        <li><a title="[wink]">[wink]</a></li>
        <li><a title="[sad]">[sad]</a></li>
        <li><a title="[cool]">[cool]</a></li>
        <li><a title="[innocent]">[innocent]</a></li>
        <li><a title="[rolleyes]">[rolleyes]</a></li>
        <li><a title="[whistling]">[whistling]</a></li>
        <li><a title="[lol]">[lol]</a></li>
        <li><a title="[huh]">[huh]</a></li>
        <li><a title="[tongue]">[tongue]</a></li>
        <li><a title="[love]">[love]</a></li>
        <li><a title="[sleeping]">[sleeping]</a></li>
        <li><a title="[yawn]">[yawn]</a></li>
        <li><a title="[unsure]">[unsure]</a></li>
        <li><a title="[angry]">[angry]</a></li>
        <li><a title="[blink]">[blink]</a></li>
        <li><a title="[crying]">[crying]</a></li>
        <li><a title="[ohmy]">[ohmy]</a></li>
        <li><a title="[scared]">[scared]</a></li>
        <li><a title="[sleep]">[sleep]</a></li>
        <li><a title="[sneaky]">[sneaky]</a></li>
        <li><a title="[tongue_smile]">[tongue_smile]</a></li>
        <li><a title="[thumbdown]">[thumbdown]</a></li>
        <li><a title="[thumbup]">[thumbup]</a></li>
        <li><a title="[censored]">[censored]</a></li>
        <li><a title="[happybirthday]">[happybirthday]</a></li>
        <li><a title="[ban]">[ban]</a></li>
        <li><a title="[spam]">[spam]</a></li>
        <li><a title="[offtopic]">[offtopic]</a></li>
        <li><a title="[batman]">[batman]</a></li>
        <li><a title="[ninja]">[ninja]</a></li>
        <li><a title="[pirate]">[pirate]</a></li>
        <li><a title="[alien]">[alien]</a></li>
        </ul>
</div>
                    
                    <div class="form-group">
                        <label class="sr-only" for="comment">Comment Text</label>
                        <textarea class="form-control" name="comment" id="comment" placeholder="Share your thoughts." required="required"></textarea>  
                    </div>
                    
                    
                
                </div>
                
                <div class="modal-footer clearfix">
                    <div class="btn-group pull-left">
                        <button type="button" class="btn btn-default" data-dismiss="modal">Cancel</button>
                    </div>
                    <div class="btn-group pull-right">
                        <button type="submit" class="btn btn-primary" data-loading-text="<span class='fas tnt-spinner tnt-spin'></span> Posting">Post comment</button>
                    </div>
                </div>

                <template id="commentPostTemplate" class="template success">
                    <div class="media comment preview">
    <div class="alert alert-dismissable alert-success">
        <button type="button" class="close" data-dismiss="alert" aria-hidden="true">&times;</button>
        <p>Your comment has been submitted.</p>
    </div>

    <div class="comment-body media-body">
        <div class="comment-user">
            <div class="avatar img-responsive"><i class="fas tnt-user tnt-fw"></i></div>
            <img class="avatar img-responsive" src="" alt="" />
        </div>
        <div class="comment-heading  media-heading">
            <strong class="username"></strong>
        </div>
        <div class="comment-text">
            <p></p>
        </div>
    </div>
</div>
</template>

            </form>
        </div>
    </div>
</div>

<div id="commentReportModal" class="modal fade">
    <div class="modal-dialog">
        <div class="modal-content">
            <div class="modal-header">
                <button type="button" class="close" data-dismiss="modal" aria-hidden="true">&times;</button>
                <h4 class="heading modal-title">Report</h4>
            </div>

            <form id="commentReport" method="post" action="/opinion/columnists/dear-abby-for-july/article_d72b5be0-8023-593f-b2bb-c3de57fe9957.html">
                <input type="hidden" name="action" value="comments:abuse" />
                <input type="hidden" name="comment_id" value="" />
        
                <div class="modal-body">
                </div>
                
                <div class="modal-footer clearfix">
                    <div class="btn-group pull-left">
                        <button type="button" class="btn btn-default" data-dismiss="modal">Cancel</button>
                    </div>
                    <div class="btn-group pull-right">
                        <button class="btn btn-danger" type="submit" data-loading-text="<span class='fas tnt-spinner tnt-spin'></span> Reporting">Report Abuse</button>
                    </div>
                </div>
        
                <template id="commentReportSuccessTemplate" class="template success">
                    <div class="reported alert alert-dismissable alert-danger"><button type="button" class="close" data-dismiss="alert" aria-hidden="true">&times;</button><p>Reported</p></div>
                </template>

                <template id="commentReportErrorTemplate" class="template error">
                    <div class="reported alert alert-dismissable alert-danger"><button type="button" class="close" data-dismiss="alert" aria-hidden="true">&times;</button><p>There was a problem reporting this.</p></div>
                </template>

            </form>

        </div>
    </div>
</div>
<div id="commentSubscribeModal" class="modal fade">
    <div class="modal-dialog">
        <div class="modal-content">
            <div class="modal-header">
                <button type="button" class="close" data-dismiss="modal" aria-hidden="true">&times;</button>
                <h4 class="heading modal-title">
                    <span class="subscribe">Watch this discussion.</span>
                    <span class="unsubscribe" style="display:none">Stop watching this discussion.</span>
                </h4>
            </div>
            <form id="commentSubscribe" method="post" action="/tncms/comment/subscribe/">
                <fieldset>
                    <legend class="sr-only">Watch this discussion</legend>
                    <input type="hidden" name="id" value="d72b5be0-8023-593f-b2bb-c3de57fe9957" />
                    <input type="hidden" name="app" value="editorial" />
                    <div class="modal-body">
                        <div class="subscribe">
                            Get an email notification whenever someone contributes to the discussion
                        </div>
                        <div class="unsubscribe" style="display:none">
                            Notifications from this discussion will be disabled.
                        </div>
                        
                    </div>
                    <div class="modal-footer clearfix">
                        <div class="btn-group pull-left">
                            <button type="button" class="btn btn-default" data-dismiss="modal">Cancel</button>
                        </div>
                        <div class="btn-group pull-right">
                            <button type="submit" class="btn btn-primary">
                                <span class="subscribe">Start watching</span>
                                <span class="unsubscribe" style="display:none">Stop watching</span>
                            </button>
                        </div>
                    </div>
                </fieldset>
            </form>
        </div>
    </div>
</div><div class="comments-container">
        <section id="comments" class=" subscriber-hide"><div class="block-title comment-count-title">
                    <div class="block-title-inner">
                        <h3>
                            <span class="fas tnt-comments"></span> (0) comments 
                            
                        </h3>
                    </div>
                </div><div id="comment-area" class="padding-bottom desc usernames">
                
            </div>
            
            <div class="comments-control-panel panel panel-default hidden-print">
                <div class="panel-body">
                    <h3>Welcome to the discussion.</h3>
                    
                    <div class="not-logged-in">
                        <p class="comment-login">
                            
    <a class="btn btn-primary btn-block" href="https://www.rocketminer.com/users/login/?referer_url=https%3A%2F%2Fwww.rocketminer.com%2Fopinion%2Fcolumnists%2Fdear-abby-for-july%2Farticle_d72b5be0-8023-593f-b2bb-c3de57fe9957.html">Log In</a>
                        </p>
                        
                    </div>
    
                    <div class="logged-in">
                        <p class="comment-rules"><strong>Keep it Clean.</strong> Please avoid obscene, vulgar, lewd,
racist or sexually-oriented language.<br>
<strong>PLEASE TURN OFF YOUR CAPS LOCK.</strong><br>
<strong>Don&#39;t Threaten.</strong> Threats of harming another
person will not be tolerated.<br>
<strong>Be Truthful.</strong> Don&#39;t knowingly lie about anyone
or anything.<br>
<strong>Be Nice.</strong> No racism, sexism or any sort of -ism
that is degrading to another person.<br>
<strong>Be Proactive.</strong> Use the &#39;Report&#39; link on
each comment to let us know of abusive posts.<br>
<strong>Share with Us.</strong> We&#39;d love to hear eyewitness
accounts, the history behind an article.
</p>
                        <div class="row">
                            <div class="col-sm-6">
                                <a class="comment-post btn btn-block btn-primary">Post a comment</a>
                            </div>
                            <div class="col-sm-6">
                                <a class="watch btn btn-block btn-default">
                                    <span class="subscribe">Watch this discussion.</span>
                                    <span class="unsubscribe">Stop watching this discussion.</span>
                                </a>
                            </div>
                        </div>
                    </div>
                </div>
            </div>
        </section>
    </div></div></div>
            </div>

            

            </div>
        </div><div class="main-sidebar col-lg-4 col-md-5 hidden-print">
                <div class="main-sidebar-wrap">
                    <div id="tncms-region-article_side_top" class="tncms-region hidden-print"></div><div id="tncms-region-asset_side_top" class="tncms-region hidden-print"></div><div id="tncms-region-global-side-primary" class="tncms-region "><div id="tncms-block-1305503" class="tncms-block"><section id="block-1305503" class="block emphasis-h3   " ><div class="clearfix">
    
    <div class="block-title title-1305503 ">
        <div class="block-title-inner">
            <h3>
                
                    <a href="/site/forms/online_services/letter_editor">
                
                Submit a Letter to the Editor
                
                    </a>
                
            </h3>
        </div>
    </div>
    <div class="block-note block-note-1305503 text-muted">
        <p>Here are some of the requirements:
•Must include: The author’s legal name, town of residence and a phone number (not for print, but for confirmation). Anonymous letters will not be printed.
•Length: The most readable letters cover issues within 250 to 350 words. Letters longer than 600 words will be trimmed or disregarded. Letters will be edited for clarity and may be cut for length.
•Guest columns: All columns, guest columns and letters will be published at the discretion of the editor.
•Submit online or send them to: editor@rocketminer.com or 215 D St., Rock Springs, WY 82901. For more information, contact the Rocket-Miner at 307-362-3736</p>
    </div>
</div><div class="card-panel panel">
        <div class="panel-body"><article class="card promo media"><div class="media-body"><p>If you're interested in submitting a Letter to the Editor, click here.</p><a href="/site/forms/online_services/letter_editor">
                <button type="button" class="btn btn-primary  ">Submit</button>
            </a></div>
</article></div>
    </div></section></div><div id="tncms-block-1305479" class="tncms-block">
    <section id="block-1305479" class="block emphasis-h3   " ><div class="clearfix">
    
    <div class="block-title title-1305479 ">
        <div class="block-title-inner">
            <h3>
                
                Featured Stories
                
            </h3>
        </div>
    </div></div>
    <div class="slideshow-carousel-container">
        
            <div id="carousel-1305479" class="card photo-carousel subscriber-hide">
            <template class="tnt-slider-template" data-swipe="true" data-arrows="true" data-auto-height="true" data-lazy-load="true">
                        <div class="item photo-99150394-6f78-5d00-bfa0-fea0af9696a8 tnt-section-rock-springs">
                            <div class="item-container">

                                <div data-track-object='{"title":"Dear Abby for July 22, 2019","url":"/opinion/columnists/dear-abby-for-july/article_d72b5be0-8023-593f-b2bb-c3de57fe9957.html","uuid":"d72b5be0-8023-593f-b2bb-c3de57fe9957","app":"editorial","metric":""}'  data-count="1"  class="photo-container layout-horizontal">
                                            <div class="loading-slide text-center"><i class="fas tnt-spinner tnt-spin"></i></div>
                                            
                                        
                                        
                                        <a href="/rock_springs/new-grouse-plan-aims-to-expand-not-just-maintain-population/article_99150394-6f78-5d00-bfa0-fea0af9696a8.html" >
                                        
        
                <img
                    src="https://bloximages.chicago2.vip.townnews.com/rocketminer.com/content/tncms/assets/v3/editorial/d/07/d07ffa7d-9dbe-5906-8aab-7db46ce6339d/5d31ed02cfa7f.image.jpg?resize=1200%2C827"
                    
                    alt="New grouse plan aims to expand, not just maintain, population"
                    class="img-responsive owl-first-image owl-lazy"
                    width="1734"
                    height="1195"
                    data-src="https://bloximages.chicago2.vip.townnews.com/rocketminer.com/content/tncms/assets/v3/editorial/d/07/d07ffa7d-9dbe-5906-8aab-7db46ce6339d/5d31ed02cfa7f.image.jpg?resize=1200%2C827" />
                                        </a>
                                        <div class="clearfix"></div>
                                </div>
        <div class="caption-container">
            <div class="caption-inner-1305479 collapse in"><div class="actions pull-right">
                <a href="http://rocketminer.mycapture.com/mycapture/remoteimage.asp?backtext=Return%20to%20photo&backurl=https%3A%2F%2Fwww.rocketminer.com%2Fopinion%2Fcolumnists%2Fdear-abby-for-july%2Farticle_d72b5be0-8023-593f-b2bb-c3de57fe9957.html&thumbpath=https%3A%2F%2Fbloximages.chicago2.vip.townnews.com%2Frocketminer.com%2Fcontent%2Ftncms%2Fassets%2Fv3%2Feditorial%2Fd%2F07%2Fd07ffa7d-9dbe-5906-8aab-7db46ce6339d%2F5d31ed02cfa7f.image.jpg%3Fresize%3D540%252C372&previewpath=https%3A%2F%2Fbloximages.chicago2.vip.townnews.com%2Frocketminer.com%2Fcontent%2Ftncms%2Fassets%2Fv3%2Feditorial%2Fd%2F07%2Fd07ffa7d-9dbe-5906-8aab-7db46ce6339d%2F5d31ed02cfa7f.image.jpg%3Fresize%3D540%252C372&notes=https://bloximages.chicago2.vip.townnews.com/rocketminer.com/content/tncms/assets/v3/editorial/d/07/d07ffa7d-9dbe-5906-8aab-7db46ce6339d/5d31ed02e1a12.~townnews~.jpg" class="tnt-photo-purchase btn btn-default btn-xs" target="_blank" rel="noopener">Buy Now</a>
            </div>
                    <div class="card-headline caption-headline">
                        <h2 class="tnt-headline ">
        
             <a href="/rock_springs/new-grouse-plan-aims-to-expand-not-just-maintain-population/article_99150394-6f78-5d00-bfa0-fea0af9696a8.html" class="tnt-asset-link">
        

        
            New grouse plan aims to expand, not just maintain, population</a></h2>
                    </div><div class="caption-text">
                        <p>LANDER – For the first time, Wyoming’s greater sage grouse team is recommending the governor adopt an explicit policy to increase the bird’s population and expand its habitat, instead of simply minimizing their declines. </p>
                    </div>
                
            </div>
        </div>
    </div>
                        </div>
                        <div class="item photo-8e20f927-e2ac-55a2-acba-afb5bbfe02ce hidden-print tnt-section-news">
                            <div class="item-container">

                                <div data-track-object='{"title":"Dear Abby for July 22, 2019","url":"/opinion/columnists/dear-abby-for-july/article_d72b5be0-8023-593f-b2bb-c3de57fe9957.html","uuid":"d72b5be0-8023-593f-b2bb-c3de57fe9957","app":"editorial","metric":""}'  data-count="2"  class="photo-container layout-vertical">
                                            <div class="loading-slide text-center"><i class="fas tnt-spinner tnt-spin"></i></div>
                                            
                                        
                                        
                                        <a href="/news/board-swears-in-new-member-passes-million-budget/article_8e20f927-e2ac-55a2-acba-afb5bbfe02ce.html" >
                                        
        
                <img
                    src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAQAAAADCAQAAAAe/WZNAAAAEElEQVR42mM8U88ABowYDABAxQPltt5zqAAAAABJRU5ErkJggg=="
                    alt="Board swears in new member, passes $47 million budget"
                    class="img-responsive owl-lazy"
                    width="317"
                    height="329"
                    data-src="https://bloximages.chicago2.vip.townnews.com/rocketminer.com/content/tncms/assets/v3/editorial/8/18/81821766-3470-548f-803d-a0d99b15adb3/5d2ff2830f2b5.image.jpg?crop=317%2C329%2C193%2C220" />
                                        </a>
                                        <div class="clearfix"></div>
                                </div>
        <div class="caption-container">
            <div class="caption-inner-1305479 collapse in">
                    <div class="card-headline caption-headline">
                        <h2 class="tnt-headline ">
        
             <a href="/news/board-swears-in-new-member-passes-million-budget/article_8e20f927-e2ac-55a2-acba-afb5bbfe02ce.html" class="tnt-asset-link">
        

        
            Board swears in new member, passes $47 million budget</a></h2>
                    </div><div class="caption-text">
                        <p>ROCK SPRINGS – After filling an open seat, the Western Wyoming Community College Board of Trustees passed a roughly $47 million budget for the 2019-20 fiscal year. </p>
                    </div>
                
            </div>
        </div>
    </div>
                        </div>
                        <div class="item photo-af596c15-6c40-5e3f-855c-3964fe623607 hidden-print tnt-section-news tnt-sub-section-local">
                            <div class="item-container">

                                <div data-track-object='{"title":"Dear Abby for July 22, 2019","url":"/opinion/columnists/dear-abby-for-july/article_d72b5be0-8023-593f-b2bb-c3de57fe9957.html","uuid":"d72b5be0-8023-593f-b2bb-c3de57fe9957","app":"editorial","metric":""}'  data-count="3"  class="photo-container layout-horizontal">
                                            <div class="loading-slide text-center"><i class="fas tnt-spinner tnt-spin"></i></div>
                                            
                                        
                                        
                                        <a href="/news/local/harbor-freight-to-open-store-in-rock-springs/article_af596c15-6c40-5e3f-855c-3964fe623607.html" >
                                        
        
                <img
                    src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAQAAAADCAQAAAAe/WZNAAAAEElEQVR42mM8U88ABowYDABAxQPltt5zqAAAAABJRU5ErkJggg=="
                    alt="Harbor Freight to open store in Rock Springs"
                    class="img-responsive owl-lazy"
                    width="720"
                    height="540"
                    data-src="https://bloximages.chicago2.vip.townnews.com/rocketminer.com/content/tncms/assets/v3/editorial/7/74/7742498b-4010-5444-8245-7209d9d13467/5b8967a8d9f85.image.jpg" />
                                        </a>
                                        <div class="clearfix"></div>
                                </div>
        <div class="caption-container">
            <div class="caption-inner-1305479 collapse in">
                    <div class="card-headline caption-headline">
                        <h2 class="tnt-headline ">
        
             <a href="/news/local/harbor-freight-to-open-store-in-rock-springs/article_af596c15-6c40-5e3f-855c-3964fe623607.html" class="tnt-asset-link">
        

        
            Harbor Freight to open store in Rock Springs</a></h2>
                    </div><div class="caption-text">
                        <p>ROCK SPRINGS -- Harbor Freight has again turned its eyes to Rock Springs. The company plans to open a store around September at 1451 Dewar Drive in the Rock Springs Plaza Mall. </p>
                    </div>
                
            </div>
        </div>
    </div>
                        </div>
                        <div class="item photo-a6136262-afe3-596d-bb3c-89227e46c101 hidden-print tnt-section-news tnt-sub-section-local">
                            <div class="item-container">

                                <div data-track-object='{"title":"Dear Abby for July 22, 2019","url":"/opinion/columnists/dear-abby-for-july/article_d72b5be0-8023-593f-b2bb-c3de57fe9957.html","uuid":"d72b5be0-8023-593f-b2bb-c3de57fe9957","app":"editorial","metric":""}'  data-count="4"  class="photo-container layout-horizontal">
                                            <div class="loading-slide text-center"><i class="fas tnt-spinner tnt-spin"></i></div>
                                            
                                        
                                        
                                        <a href="/news/local/reminder-rocket-miner-goes-to-two-day-publication-this-week/article_a6136262-afe3-596d-bb3c-89227e46c101.html" >
                                        
        
                <img
                    src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAQAAAADCAQAAAAe/WZNAAAAEElEQVR42mM8U88ABowYDABAxQPltt5zqAAAAABJRU5ErkJggg=="
                    alt="Reminder: Rocket-Miner goes to two-day publication this week"
                    class="img-responsive owl-lazy"
                    width="1650"
                    height="1096"
                    data-src="https://bloximages.chicago2.vip.townnews.com/rocketminer.com/content/tncms/assets/v3/editorial/b/5f/b5f2ed3d-0577-5621-b0dd-858e1ae3e0d5/5d289bc4d36ce.image.jpg?resize=1200%2C797" />
                                        </a>
                                        <div class="clearfix"></div>
                                </div>
        <div class="caption-container">
            <div class="caption-inner-1305479 collapse in"><div class="actions pull-right">
                <a href="http://rocketminer.mycapture.com/mycapture/remoteimage.asp?backtext=Return%20to%20photo&backurl=https%3A%2F%2Fwww.rocketminer.com%2Fopinion%2Fcolumnists%2Fdear-abby-for-july%2Farticle_d72b5be0-8023-593f-b2bb-c3de57fe9957.html&thumbpath=https%3A%2F%2Fbloximages.chicago2.vip.townnews.com%2Frocketminer.com%2Fcontent%2Ftncms%2Fassets%2Fv3%2Feditorial%2Fb%2F5f%2Fb5f2ed3d-0577-5621-b0dd-858e1ae3e0d5%2F5d289bc4d36ce.image.jpg%3Fresize%3D540%252C359&previewpath=https%3A%2F%2Fbloximages.chicago2.vip.townnews.com%2Frocketminer.com%2Fcontent%2Ftncms%2Fassets%2Fv3%2Feditorial%2Fb%2F5f%2Fb5f2ed3d-0577-5621-b0dd-858e1ae3e0d5%2F5d289bc4d36ce.image.jpg%3Fresize%3D540%252C359&notes=https://bloximages.chicago2.vip.townnews.com/rocketminer.com/content/tncms/assets/v3/editorial/b/5f/b5f2ed3d-0577-5621-b0dd-858e1ae3e0d5/5d289bc4e3682.~townnews~.jpg" class="tnt-photo-purchase btn btn-default btn-xs" target="_blank" rel="noopener">Buy Now</a>
            </div>
                    <div class="card-headline caption-headline">
                        <h2 class="tnt-headline ">
        
             <a href="/news/local/reminder-rocket-miner-goes-to-two-day-publication-this-week/article_a6136262-afe3-596d-bb3c-89227e46c101.html" class="tnt-asset-link">
        

        
            Reminder: Rocket-Miner goes to two-day publication this week</a></h2>
                    </div><div class="caption-text">
                        <p>ROCK SPRINGS — As we first announced in June, the Rock Springs Rocket-Miner newspaper will become a Wednesday and Saturday publication starting Wednesday, July 17. </p>
                    </div>
                
            </div>
        </div>
    </div>
                        </div>
                        <div class="item photo-40319421-a439-522d-9517-2f209f61f0a6 hidden-print tnt-section-news tnt-sub-section-state">
                            <div class="item-container">

                                <div data-track-object='{"title":"Dear Abby for July 22, 2019","url":"/opinion/columnists/dear-abby-for-july/article_d72b5be0-8023-593f-b2bb-c3de57fe9957.html","uuid":"d72b5be0-8023-593f-b2bb-c3de57fe9957","app":"editorial","metric":""}'  data-count="5"  class="photo-container layout-horizontal">
                                            <div class="loading-slide text-center"><i class="fas tnt-spinner tnt-spin"></i></div>
                                            
                                        
                                        
                                        <a href="/news/state/ski-resort-structure-goes-up-in-flames/article_40319421-a439-522d-9517-2f209f61f0a6.html" >
                                        
        
                <img
                    src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAQAAAADCAQAAAAe/WZNAAAAEElEQVR42mM8U88ABowYDABAxQPltt5zqAAAAABJRU5ErkJggg=="
                    alt="Ski resort structure goes up in flames"
                    class="img-responsive owl-lazy"
                    width="390"
                    height="292"
                    data-src="https://bloximages.chicago2.vip.townnews.com/rocketminer.com/content/tncms/assets/v3/editorial/3/97/397db170-af25-5b14-a366-4e380829b3d2/5d28fab099ad5.image.jpg" />
                                        </a>
                                        <div class="clearfix"></div>
                                </div>
        <div class="caption-container">
            <div class="caption-inner-1305479 collapse in">
                    <div class="card-headline caption-headline">
                        <h2 class="tnt-headline ">
        
             <a href="/news/state/ski-resort-structure-goes-up-in-flames/article_40319421-a439-522d-9517-2f209f61f0a6.html" class="tnt-asset-link">
        

        
            Ski resort structure goes up in flames</a></h2>
                    </div><div class="caption-text">
                        <p>PINEDALE — There were no injuries reported after a fire occurred at the White Pine Ski Resort early Friday morning. </p>
                    </div>
                
            </div>
        </div>
    </div>
                        </div>
            </template>
        </div>
        
        
    </div></section></div><div id="tncms-block-1317430" class="tncms-block">
        <div id="blox-ad-position-rail-top1" data-tnt-ads='{"vendor":"blox","type":"position","display":"default","region":"rail-top","slot":"1","fold":"above","width":"300","js":{"video":"https:\/\/bloximages.chicago2.vip.townnews.com\/rocketminer.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/video\/resources\/scripts\/video.512a6903eae08e033c76afdce2a0eac7.js"},"overline":"","refresh":false}' class="blox-ad tnt-ads-container ">
        
        </div></div><div id="tncms-block-1317587" class="tncms-block">
        <div id="blox-ad-position-rail-top2" data-tnt-ads='{"vendor":"blox","type":"position","display":"default","region":"rail-top","slot":"2","fold":"above","width":"300","js":{"video":"https:\/\/bloximages.chicago2.vip.townnews.com\/rocketminer.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/video\/resources\/scripts\/video.512a6903eae08e033c76afdce2a0eac7.js"},"overline":"","refresh":false}' class="blox-ad tnt-ads-container ">
        
        </div></div><div id="tncms-block-1305492" class="tncms-block"><section id="block-1305492" class="block emphasis-h4   " ><div class="clearfix">
    
    <div class="block-title title-1305492 ">
        <div class="block-title-inner">
            <h4>
                
                Most Popular
                
            </h4>
        </div>
    </div></div><div class="most-popular">
    <ul class="nav nav-tabs nav-tabs-popular">
        
            <li class="active">
                <a href="#articles-1305492" data-toggle="tab"><i class="far tnt-file-alt" title="Articles"></i><span class="tab-text"> Articles</span></a>
            </li>
        
        
            <li >
                <a href="#images-1305492" data-toggle="tab"><i class="far tnt-image" title="images"></i><span class="tab-text"> Images</span></a>
            </li>
        
        
            <li >
                <a href="#videos-1305492" data-toggle="tab"><i class="fas tnt-play-circle" title="Videos"></i><span class="tab-text"> Videos</span></a>
            </li>
        
        
        
        
            <li >
                <a href="#commented-1305492" data-toggle="tab"><i class="far tnt-comments" title="Commented"></i><span class="tab-text"> Commented</span></a>
            </li>
        
    </ul>
    <div class="tab-content">
        
            <div id="articles-1305492" class="tab-pane tab-pane-articles fade in active">
                <h4 class="tab-content-heading">Articles</h4><ul class="tab-content-list bullet-disc "><li><a href="/news/local/harbor-freight-to-open-store-in-rock-springs/article_af596c15-6c40-5e3f-855c-3964fe623607.html">Harbor Freight to open store in Rock Springs</a></li><li><a href="/news/local/search-suspended-for-aubree-corona/article_018502a9-e103-55af-98eb-e611f33b8076.html">Search suspended for Aubree Corona</a></li><li><a href="/sports/rodeo/national-high-school-finals-rodeo-results-as-of-thursday-afternoon/article_3782c003-ef62-5c48-b33b-3ad129eefde3.html">National High School Finals Rodeo results (as of Thursday afternoon)</a></li><li><a href="/sports/community_sports/little-stars-with-big-talents/article_5271a226-69fd-5e97-9ec7-1f9fa29482ed.html">Little stars with big talents</a></li><li><a href="/news/local/reminder-rocket-miner-goes-to-two-day-publication-this-week/article_a6136262-afe3-596d-bb3c-89227e46c101.html">Reminder: Rocket-Miner goes to two-day publication this week</a></li><li><a href="/sports/rodeo/national-champs-crowned-see-short-go-results-from-the-nhsfr/article_9fd14d84-9c75-5cd4-b21e-e75791537814.html">National champs crowned: See short go results from the NHSFR</a></li><li><a href="/sports/rodeo/national-high-school-rodeo-finals-results-as-of-friday-afternoon/article_9d7b7a7d-6bb8-55c3-9cdd-b20cc8d993df.html">National High School Rodeo Finals results as of Friday afternoon</a></li><li><a href="/obituaries/laurie-macioszek/article_f57da9bd-4ec0-5b91-9943-71e61c05d9f2.html">Laurie Macioszek</a></li><li><a href="/obituaries/jason-leon-doan/article_6d7ce600-e96a-5efa-b2cd-4086171a6665.html">Jason Leon Doan</a></li><li><a href="/news/local/person-dies-in-pinedale-house-fire/article_d2b9a151-6386-5b5a-8909-7b16e2a3bd77.html">1 person dies in Pinedale house fire</a></li></ul></div>
        
        
            <div id="images-1305492" class="tab-pane tab-pane-images fade in ">
                <h4 class="tab-content-heading">Images</h4><ul class="tab-content-list">
                            <li><figure class="photo layout-square">
            <div class="image" 
                >
                
                    <a href="/community/entertainment/crossword-puzzle-for-july/image_27de79ef-26bf-5a25-9b83-2119d60bd3b9.html" class="tnt-asset-link">
                
                
                
                
        
                    <img
                        src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAEAAAABCAQAAAC1HAwCAAAAC0lEQVR42mM8Uw8AAh0BTZud3BwAAAAASUVORK5CYII="
                        alt="Crossword puzzle for July 20, 2019"
                        class="img-responsive lazyload full"
                        width="1008"
                        height="1008"
                        data-sizes="auto"
                        data-srcset="https://bloximages.chicago2.vip.townnews.com/rocketminer.com/content/tncms/assets/v3/editorial/2/7d/27de79ef-26bf-5a25-9b83-2119d60bd3b9/5d321ba48d5a3.image.jpg?crop=1008%2C1008%2C0%2C522&resize=100%2C100&order=crop%2Cresize 100w" />
                </a>
            </div>
            
        </figure></li>
                        
                            <li><figure class="photo layout-square">
            <div class="image" 
                >
                
                    <a href="/opinion/cartoons/editorial-cartoon-for-july/image_07cfb093-4e7d-54a7-a8b3-bde3eb33e130.html" class="tnt-asset-link">
                
                
                
                
        
                    <img
                        src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAEAAAABCAQAAAC1HAwCAAAAC0lEQVR42mM8Uw8AAh0BTZud3BwAAAAASUVORK5CYII="
                        alt="Editorial cartoon for July 16, 2019"
                        class="img-responsive lazyload full"
                        width="1227"
                        height="1227"
                        data-sizes="auto"
                        data-srcset="https://bloximages.chicago2.vip.townnews.com/rocketminer.com/content/tncms/assets/v3/editorial/0/7c/07cfb093-4e7d-54a7-a8b3-bde3eb33e130/5d2d212c65910.image.jpg?crop=1227%2C1227%2C230%2C0&resize=100%2C100&order=crop%2Cresize 100w" />
                </a>
            </div>
            
        </figure></li>
                        
                            <li><figure class="photo layout-square">
            <div class="image" 
                >
                
                    <a href="/news/local/changing-delivery/image_6c5cf776-ed6e-5165-8164-8845e8c5feb6.html" class="tnt-asset-link">
                
                
                
                
        
                    <img
                        src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAEAAAABCAQAAAC1HAwCAAAAC0lEQVR42mM8Uw8AAh0BTZud3BwAAAAASUVORK5CYII="
                        alt="Changing delivery"
                        class="img-responsive lazyload full"
                        width="437"
                        height="437"
                        data-sizes="auto"
                        data-srcset="https://bloximages.chicago2.vip.townnews.com/rocketminer.com/content/tncms/assets/v3/editorial/6/c5/6c5cf776-ed6e-5165-8164-8845e8c5feb6/5d2dfd2edcda3.image.jpg?crop=437%2C437%2C0%2C122&resize=100%2C100&order=crop%2Cresize 100w" />
                </a>
            </div>
            
        </figure></li>
                        
                            <li><figure class="photo layout-square">
            <div class="image" 
                >
                
                    <a href="/taking-a-break-between-events/image_18d39860-842c-514d-9562-416abb4dd5c5.html" class="tnt-asset-link">
                
                
                
                
        
                    <img
                        src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAEAAAABCAQAAAC1HAwCAAAAC0lEQVR42mM8Uw8AAh0BTZud3BwAAAAASUVORK5CYII="
                        alt="Taking a break between events"
                        class="img-responsive lazyload full"
                        width="1171"
                        height="1171"
                        data-sizes="auto"
                        data-srcset="https://bloximages.chicago2.vip.townnews.com/rocketminer.com/content/tncms/assets/v3/editorial/1/8d/18d39860-842c-514d-9562-416abb4dd5c5/5d3229bd9b91e.image.jpg?crop=1171%2C1171%2C299%2C0&resize=100%2C100&order=crop%2Cresize 100w" />
                </a>
            </div>
            
        </figure></li>
                        
                            <li><figure class="photo layout-square">
            <div class="image" 
                >
                
                    <a href="/opinion/cartoons/editorial-cartoon-for-july/image_33722997-eef0-5374-b8f2-4cd76ef2154b.html" class="tnt-asset-link">
                
                
                
                
        
                    <img
                        src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAEAAAABCAQAAAC1HAwCAAAAC0lEQVR42mM8Uw8AAh0BTZud3BwAAAAASUVORK5CYII="
                        alt="Editorial cartoon for July 20, 2019"
                        class="img-responsive lazyload full"
                        width="1237"
                        height="1237"
                        data-sizes="auto"
                        data-srcset="https://bloximages.chicago2.vip.townnews.com/rocketminer.com/content/tncms/assets/v3/editorial/3/37/33722997-eef0-5374-b8f2-4cd76ef2154b/5d321a3d549d3.image.jpg?crop=1237%2C1237%2C218%2C0&resize=100%2C100&order=crop%2Cresize 100w" />
                </a>
            </div>
            
        </figure></li>
                        
                            <li><figure class="photo layout-square">
            <div class="image" 
                >
                
                    <a href="/community/entertainment/sudoku-for-july/image_9ba09b35-0b39-5681-9e6f-2ba901689be4.html" class="tnt-asset-link">
                
                
                
                
        
                    <img
                        src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAEAAAABCAQAAAC1HAwCAAAAC0lEQVR42mM8Uw8AAh0BTZud3BwAAAAASUVORK5CYII="
                        alt="Sudoku for July 20, 2019"
                        class="img-responsive lazyload full"
                        width="430"
                        height="430"
                        data-sizes="auto"
                        data-srcset="https://bloximages.chicago2.vip.townnews.com/rocketminer.com/content/tncms/assets/v3/editorial/9/ba/9ba09b35-0b39-5681-9e6f-2ba901689be4/5d321ab3a7167.image.jpg?crop=430%2C430%2C170%2C0&resize=100%2C100&order=crop%2Cresize 100w" />
                </a>
            </div>
            
        </figure></li>
                        
                            <li><figure class="photo layout-square">
            <div class="image" 
                >
                
                    <a href="/community/entertainment/sudoku-for-july/image_32532826-2a74-5bae-adf3-7bc1ab075a1d.html" class="tnt-asset-link">
                
                
                
                
        
                    <img
                        src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAEAAAABCAQAAAC1HAwCAAAAC0lEQVR42mM8Uw8AAh0BTZud3BwAAAAASUVORK5CYII="
                        alt="Sudoku for July 17, 2019"
                        class="img-responsive lazyload full"
                        width="924"
                        height="924"
                        data-sizes="auto"
                        data-srcset="https://bloximages.chicago2.vip.townnews.com/rocketminer.com/content/tncms/assets/v3/editorial/3/25/32532826-2a74-5bae-adf3-7bc1ab075a1d/5d2d507a60a23.image.jpg?crop=924%2C924%2C359%2C0&resize=100%2C100&order=crop%2Cresize 100w" />
                </a>
            </div>
            
        </figure></li>
                        
                            <li><figure class="photo layout-square">
            <div class="image" 
                >
                
                    <a href="/opinion/cartoons/editorial-cartoon-for-july/image_deb00d79-7eff-5012-b6cd-4cb31d86fc3e.html" class="tnt-asset-link">
                
                
                
                
        
                    <img
                        src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAEAAAABCAQAAAC1HAwCAAAAC0lEQVR42mM8Uw8AAh0BTZud3BwAAAAASUVORK5CYII="
                        alt="Editorial cartoon for July 17, 2019"
                        class="img-responsive lazyload full"
                        width="1282"
                        height="1282"
                        data-sizes="auto"
                        data-srcset="https://bloximages.chicago2.vip.townnews.com/rocketminer.com/content/tncms/assets/v3/editorial/d/eb/deb00d79-7eff-5012-b6cd-4cb31d86fc3e/5d2d20772cdde.image.jpg?crop=1282%2C1282%2C166%2C0&resize=100%2C100&order=crop%2Cresize 100w" />
                </a>
            </div>
            
        </figure></li>
                        
                            <li><figure class="photo layout-square">
            <div class="image" 
                >
                
                    <a href="/community/entertainment/sudoku-for-july/image_e1ccf4a4-0cd4-5ad2-a470-94dd44934d24.html" class="tnt-asset-link">
                
                
                
                
        
                    <img
                        src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAEAAAABCAQAAAC1HAwCAAAAC0lEQVR42mM8Uw8AAh0BTZud3BwAAAAASUVORK5CYII="
                        alt="Sudoku for July 16, 2019"
                        class="img-responsive lazyload full"
                        width="940"
                        height="940"
                        data-sizes="auto"
                        data-srcset="https://bloximages.chicago2.vip.townnews.com/rocketminer.com/content/tncms/assets/v3/editorial/e/1c/e1ccf4a4-0cd4-5ad2-a470-94dd44934d24/5d2d507a3886d.image.jpg?crop=940%2C940%2C361%2C0&resize=100%2C100&order=crop%2Cresize 100w" />
                </a>
            </div>
            
        </figure></li>
                        
                            <li><figure class="photo layout-square">
            <div class="image" 
                >
                
                    <a href="/community/entertainment/sudoku-for-july/image_d1b0b232-0466-5286-85ef-abed336ba24c.html" class="tnt-asset-link">
                
                
                
                
        
                    <img
                        src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAEAAAABCAQAAAC1HAwCAAAAC0lEQVR42mM8Uw8AAh0BTZud3BwAAAAASUVORK5CYII="
                        alt="Sudoku for July 22, 2019"
                        class="img-responsive lazyload full"
                        width="437"
                        height="437"
                        data-sizes="auto"
                        data-srcset="https://bloximages.chicago2.vip.townnews.com/rocketminer.com/content/tncms/assets/v3/editorial/d/1b/d1b0b232-0466-5286-85ef-abed336ba24c/5d321ab3c4953.image.jpg?crop=437%2C437%2C166%2C0&resize=100%2C100&order=crop%2Cresize 100w" />
                </a>
            </div>
            
        </figure></li>
                        </ul></div>
        
        <div id="videos-1305492" class="tab-pane tab-pane-videos fade in ">
                <h4 class="tab-content-heading">Videos</h4><p class="no-results text-muted">Sorry, there are no recent results for popular videos.</p></div>
        
        
        
        
            <div id="commented-1305492" class="tab-pane tab-pane-commented fade in ">
                <h4 class="tab-content-heading">Commented</h4><p class="no-results text-muted">Sorry, there are no recent results for popular commented articles.</p></div>
        
    </div>
</div></section></div><div id="tncms-block-1317432" class="tncms-block">
        <div id="blox-ad-position-rail-middle1" data-tnt-ads='{"vendor":"blox","type":"position","display":"default","region":"rail-middle","slot":"1","fold":"","width":"300","js":{"video":"https:\/\/bloximages.chicago2.vip.townnews.com\/rocketminer.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/video\/resources\/scripts\/video.512a6903eae08e033c76afdce2a0eac7.js"},"overline":"","refresh":false}' class="blox-ad tnt-ads-container ">
        
        </div></div><div id="tncms-block-1539091" class="tncms-block"><div id="ap_widget_container_8e10d4f1b2e07aa40eb42c96d1fd899a"></div>
<script src="https://digitalservices.ap.org/widget-content/8e10d4f1b2e07aa40eb42c96d1fd899a"></script></div><div id="tncms-block-1539092" class="tncms-block"><div id="ap_widget_container_05cc54af60f9e58e4ee6fa29cedc81c3"></div>
<script src="https://digitalservices.ap.org/widget-content/05cc54af60f9e58e4ee6fa29cedc81c3"></script></div><div id="tncms-block-1305566" class="tncms-block"><section id="block-1305566" class="block emphasis-h4   " ><div class="clearfix">
    
    <div class="block-title title-1305566 ">
        <div class="block-title-inner">
            <h4>
                
                Latest e-Edition
                
            </h4>
        </div>
    </div></div>
    
        
            <div class="card-panel panel">
                <div class="panel-body">
        <article id="card-summary-7316e8c6-cd34-5988-bd47-f99c7c44c606" class="clearfix card summary">
                <div class="card-container">
                        <div class="card-image">
                            <div class="media-preview-7316e8c6-cd34-5988-bd47-f99c7c44c606 media-preview edition-asset" data-aspect=""><figure class="photo layout-vertical">
            <div class="image" 
                >
                
                    <a href="/eedition/erocket/edition_7316e8c6-cd34-5988-bd47-f99c7c44c606.html" class="tnt-asset-link">
                
                
                    <div class="asset-icon"><i class="far tnt-newspaper tnt-fw" title="e-Edition"></i></div>
                
                
                
        
                    <img
                        src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAQAAAADCAQAAAAe/WZNAAAAEElEQVR42mM8U88ABowYDABAxQPltt5zqAAAAABJRU5ErkJggg=="
                        alt="eRocket"
                        class="img-responsive lazyload full"
                        width="300"
                        height="547"
                        data-sizes="auto"
                        data-srcset="https://bloximages.chicago2.vip.townnews.com/rocketminer.com/content/tncms/assets/v3/eedition/8/81/88193339-7352-59b8-a889-20a26608307e/5d325f6c65665.preview-300.jpg?resize=200%2C365 200w, https://bloximages.chicago2.vip.townnews.com/rocketminer.com/content/tncms/assets/v3/eedition/8/81/88193339-7352-59b8-a889-20a26608307e/5d325f6c65665.preview-300.jpg?resize=300%2C547 300w" />
                </a>
            </div>
            
        </figure>
    </div>
                        </div>
                    <div class="card-body">
                        <div class="card-headline">
                            <h3 class="tnt-headline ">
        
             <a href="/eedition/erocket/edition_7316e8c6-cd34-5988-bd47-f99c7c44c606.html" class="tnt-asset-link">
        

        
            eRocket</a></h3>
                        </div>
                            <div class="card-meta">
                                <ul class="list-inline">
                                    
                                    
                                        <li style="padding-bottom:10px;">To view our latest e-Edition click the image on the left.</li>
                                    </ul>
                            </div>
                    </div>
                </div>
                <div class="clearfix"></div>
            </article>
                </div>
            </div>
        
    
    </section></div><div id="tncms-block-1305475" class="tncms-block"></div></div><div id="tncms-region-asset_side_middle" class="tncms-region hidden-print"></div><div id="tncms-region-article_side_middle" class="tncms-region hidden-print"></div><div id="tncms-region-global-side-secondary" class="tncms-region hidden-print"><div id="tncms-block-1305557" class="tncms-block"></div><div id="tncms-block-1305471" class="tncms-block"></div><div id="tncms-block-1305476" class="tncms-block"><section id="block-1305476" class="block emphasis-h4   " ><div class="clearfix">
    
    <div class="block-title title-1305476 ">
        <div class="block-title-inner">
            <h4>
                
                    <a href="/stock_market">
                
                Stocks
                
                    </a>
                
            </h4>
        </div>
    </div></div><div class="tradingview-widget-container">
    <div class="tradingview-widget-container__widget"></div>
    <div class="tradingview-widget-copyright">
        <a href="https://www.tradingview.com" rel="noopener" target="_blank">
            <span class="blue-text">Market Data</span> by TradingView
        </a>
    </div>
    <script src="https://s3.tradingview.com/external-embedding/embed-widget-market-overview.js" async>{"whitelabel":true,"locale":"en","width":"100%","height":"660","plotLineColorGrowing":"rgba(60, 188, 152, 1)","plotLineColorFalling":"rgba(255, 74, 104, 1)","gridLineColor":"rgba(233, 233, 234, 1)","scaleFontColor":"rgba(218, 221, 224, 1)","belowLineFillColorGrowing":"rgba(60, 188, 152, 0.05)","belowLineFillColorFalling":"rgba(255, 74, 104, 0.05)","tabs":[{"title":"Equities","symbols":[{"d":"S&P 500","s":"OANDA:SPX500USD"},{"d":"Shanghai Composite","s":"INDEX:XLY0"},{"d":"Dow 30","s":"FOREXCOM:DJI"},{"d":"Nikkei 225","s":"INDEX:NKY"},{"d":"Apple","s":"NASDAQ:AAPL"},{"d":"Google","s":"NASDAQ:GOOG"}]},{"title":"Commodities","symbols":[{"d":"E-Mini S&P","s":"CME_MINI:ES1!"},{"d":"Euro","s":"CME:E61!"},{"d":"Gold","s":"COMEX:GC1!"},{"d":"Crude Oil","s":"NYMEX:CL1!"},{"d":"Natural Gas","s":"NYMEX:NG1!"},{"d":"Corn","s":"CBOT:ZC1!"}]},{"title":"Bonds","symbols":[{"d":"US 2YR","s":"CBOT:TUZ2019"},{"d":"US 10YR","s":"CBOT:TYZ2019"},{"d":"US 30YR","s":"CBOT:USZ2019"},{"d":"Euro Bund","s":"EUREX:GG1!"},{"d":"Euro BTP","s":"EUREX:II1!"},{"d":"Euro BOBL","s":"EUREX:HR1!"}]},{"title":"Forex","symbols":[{"d":"EURUSD","s":"FX:EURUSD"},{"d":"GBPUSD","s":"FX:GBPUSD"},{"d":"USDJPY","s":"FX:USDJPY"},{"d":"USDCHF","s":"FX:USDCHF"},{"d":"AUDUSD","s":"FX:AUDUSD"},{"d":"USDCAD","s":"FX:USDCAD"}]}],"largeChartUrl":"http:\/\/www.rocketminer.com\/stock_market"}</script>
    </div></section></div><div id="tncms-block-1524641" class="tncms-block"><div id="ap_widget_container_e90d045be76333ca3f0691a2739d9522"></div>
<script src="https://digitalservices.ap.org/widget-content/e90d045be76333ca3f0691a2739d9522"></script></div></div><div id="tncms-region-asset_side_bottom" class="tncms-region hidden-print"></div><div id="tncms-region-global-side-tertiary" class="tncms-region "></div><div id="tncms-region-article_side_bottom" class="tncms-region hidden-print"></div><div id="insticator-container" style="position:relative;margin-left:auto;margin-right:auto;width:300px;margin-bottom:40px;">
                    <div id="div-insticator-ad-1"></div>
                    <div id="insticator-embed"></div>
                    <div id="div-insticator-ad-2"></div>
                </div>
                <div id="sticky-right-rail-spacer">
                    <div id="sticky-right-rail"><div id="tncms-region-global-side-sticky" class="tncms-region hidden-print"></div><div id="tncms-region-asset_side_sticky" class="tncms-region hidden-print"></div></div>
                </div>
                </div>
            </div></div>
</article>



        <div class="row">
            <div class="col-md-12"><div id="tncms-region-global-container-bottom" class="tncms-region "><div id="tncms-block-1305434" class="tncms-block hidden-xs">
        <div id="blox-ad-position-leaderboard-bottom1" data-tnt-ads='{"vendor":"blox","type":"position","display":"default","region":"leaderboard-bottom","slot":"1","fold":"below","width":"728","js":{"video":"https:\/\/bloximages.chicago2.vip.townnews.com\/rocketminer.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/video\/resources\/scripts\/video.512a6903eae08e033c76afdce2a0eac7.js"},"overline":"","refresh":false}' class="blox-ad tnt-ads-container ">
        
        </div></div><div id="tncms-block-1379860" class="tncms-block"><div class="tnt-ads-container text-center  " >
        <div id="ad-1379860" class="tnt-ads dfp-ad" >
            <script>
                googletag.cmd.push(function() {
                        googletag.display('ad-1379860');
                        
                });
            </script>
        </div>
    </div>
</div><div id="tncms-block-1305435" class="tncms-block visible-xs">
        <div id="blox-ad-position-block-leaderboard-bottom-mobile1" data-tnt-ads='{"vendor":"blox","type":"position","display":"default","region":"block-leaderboard-bottom-mobile","slot":"1","fold":"below","width":"320","js":{"video":"https:\/\/bloximages.chicago2.vip.townnews.com\/rocketminer.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/video\/resources\/scripts\/video.512a6903eae08e033c76afdce2a0eac7.js"},"overline":"","refresh":false}' class="blox-ad tnt-ads-container ">
        
        </div></div></div></div>
        </div></section>
    <section id="main-bottom-container" class="container-fullscreen-region container-fluid">
        <div class="fullscreen-region"><div id="tncms-region-global-container-bottom-fullscreen" class="tncms-region "></div></div>
    </section><!-- / main-body-container -->
    </div>
    <div id="site-footer-container" class="hidden-print">
         
            <div class="container">
                <div id="asset-container-bottom" class="col-md-12">
                    <div id="tncms-region-asset_container_bottom" class="tncms-region hidden-print"></div> 
                </div>
            </div>
        

        
            <footer id="site-footer" class="container well-main">
                
                <div id="tncms-region-footer-top-col-full" class="tncms-region "></div>
                <div class="row">
                    <div id="footer-col-one" class="col-md-4 col-sm-4"><div id="tncms-region-footer-col-one" class="tncms-region "><div id="tncms-block-1305560" class="tncms-block"><section id="block-1305560" class="block emphasis-h4   " ><div class="clearfix">
    
    <div class="block-title title-1305560 ">
        <div class="block-title-inner">
            <h4>
                
                Sections
                
            </h4>
        </div>
    </div></div></section></div></div><div id="tncms-region-nav-footer-col-one-nav" class="tncms-region-nav"><ul id="footer-col-one-nav_menu" class="bullet-nav nav-list"><li>
                <a class="nav-link nav-home  tnt-section-home"  href="/" >
                    <span class="nav-icon fas tnt-home tnt-fw"></span> <span class="nav-label">Home</span>
                </a></li><li>
                <a class="nav-link  tnt-section-news"  href="/news/" >
                    <span class="nav-label">News</span>
                </a></li><li>
                <a class="nav-link  tnt-section-sports"  href="/sports/" >
                    <span class="nav-label">Sports</span>
                </a></li><li>
                <a class="nav-link  tnt-section-community"  href="/community/" >
                    <span class="nav-label">Community</span>
                </a></li><li>
                <a class="nav-link  tnt-section-opinion"  href="/opinion/" >
                    <span class="nav-label">Opinion</span>
                </a></li><li>
                <a class="nav-link  tnt-section-records"  href="/records/" >
                    <span class="nav-label">Records</span>
                </a></li><li>
                <a class="nav-link  tnt-section-obituaries"  href="/obituaries/" >
                    <span class="nav-label">Obituaries</span>
                </a></li><li>
                <a class="nav-link  tnt-section-opinion"  href="/opinion/" >
                    <span class="nav-label">Opinion</span>
                </a></li><li>
                <a class="nav-link  tnt-section-multimedia"  href="/multimedia/" >
                    <span class="nav-label">Multimedia</span>
                </a></li><li>
                <a class="nav-link  tnt-section-online-features"  href="/online_features/" >
                    <span class="nav-label">Online Features</span>
                </a></li></ul></div></div>
    <div id="footer-col-two" class="col-md-4 col-sm-4"><div id="tncms-region-footer-col-two" class="tncms-region "><div id="tncms-block-1305483" class="tncms-block"><section id="block-1305483" class="block emphasis-h4   " ><div class="clearfix">
    
    <div class="block-title title-1305483 ">
        <div class="block-title-inner">
            <h4>
                
                Services
                
            </h4>
        </div>
    </div></div></section></div></div><div id="tncms-region-nav-footer-col-two-nav" class="tncms-region-nav"><ul id="footer-col-two-nav_menu" class="bullet-nav nav-list"><li>
                <a class="nav-link  tnt-section-subscription-services"  href="/site/forms/subscription_services/" >
                    <span class="nav-label">Subscription Services</span>
                </a></li><li>
                <a class="nav-link  tnt-section-submission-forms"  href="/site/forms/" >
                    <span class="nav-label">Submission Forms</span>
                </a></li><li>
                <a class="nav-link  tnt-section-classifieds"  href="/classifieds/" >
                    <span class="nav-label">Classifieds</span>
                </a></li><li>
                <a class="nav-link  tnt-section-calendar"  href="/calendar/" >
                    <span class="nav-label">Calendar</span>
                </a></li><li>
                <a class="nav-link  tnt-section-search"  href="/search/" >
                    <span class="nav-label">Search</span>
                </a></li><li>
                <a class="nav-link  tnt-section-weather"  href="/weather/" >
                    <span class="nav-label">Weather</span>
                </a></li><li>
                <a class="nav-link  tnt-section-meet-the-team"  href="/site/contact.html" >
                    <span class="nav-label">Meet the Team</span>
                </a></li><li>
                <a class="nav-link  tnt-section-apg-job-openings"  href="http://adamspg.com/careers/"  target="_blank" rel="noopener">
                    <span class="nav-label">APG Job Openings</span>
                </a></li><li class="dropdown">
                <a class="nav-link dropdown-toggle  tnt-section-partner-papers"  data-toggle="dropdown" data-target="#"    >
                    <span class="nav-label">Partner Papers</span>
                </a><ul id="footer-col-two-nav_menu-child-9" class="dropdown-menu"><li>
                <a class="nav-link  tnt-section-wyoming-tribune-eagle"  href="http://www.wyomingnews.com/"  target="_blank" rel="noopener">
                    <span class="nav-label">Wyoming Tribune Eagle</span>
                </a></li><li>
                <a class="nav-link  tnt-section-laramie-boomerang"  href="http://www.laramieboomerang.com/"  target="_blank" rel="noopener">
                    <span class="nav-label">Laramie Boomerang</span>
                </a></li><li>
                <a class="nav-link  tnt-section-rawlins-daily-times"  href="http://www.rawlinstimes.com/"  target="_blank" rel="noopener">
                    <span class="nav-label">Rawlins Daily Times</span>
                </a></li><li>
                <a class="nav-link  tnt-section-wyoming-business-report"  href="http://www.wyomingbusinessreport.com"  target="_blank" rel="noopener">
                    <span class="nav-label">Wyoming Business Report</span>
                </a></li></ul></li></ul></div></div>
    <div id="footer-col-three" class="col-md-4 col-sm-4"><div id="tncms-region-footer-col-three" class="tncms-region "><div id="tncms-block-1305565" class="tncms-block padding-bottom"><section id="block-1305565" class="block emphasis-h3   " ><div class="block"><a href="/" rel="nofollow" ><img 
            
            src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAQAAAADCAQAAAAe/WZNAAAAEElEQVR42mM8U88ABowYDABAxQPltt5zqAAAAABJRU5ErkJggg==" 
            data-srcset="https://bloximages.chicago2.vip.townnews.com/rocketminer.com/content/tncms/custom/image/ae2435be-a060-11e6-bdb3-e304e22b1b60.png?resize=200%2C25 200w, https://bloximages.chicago2.vip.townnews.com/rocketminer.com/content/tncms/custom/image/ae2435be-a060-11e6-bdb3-e304e22b1b60.png?resize=300%2C38 300w, https://bloximages.chicago2.vip.townnews.com/rocketminer.com/content/tncms/custom/image/ae2435be-a060-11e6-bdb3-e304e22b1b60.png?resize=400%2C51 400w, https://bloximages.chicago2.vip.townnews.com/rocketminer.com/content/tncms/custom/image/ae2435be-a060-11e6-bdb3-e304e22b1b60.png?resize=540%2C69 540w, https://bloximages.chicago2.vip.townnews.com/rocketminer.com/content/tncms/custom/image/ae2435be-a060-11e6-bdb3-e304e22b1b60.png?resize=750%2C95 750w, https://bloximages.chicago2.vip.townnews.com/rocketminer.com/content/tncms/custom/image/ae2435be-a060-11e6-bdb3-e304e22b1b60.png 1200w" 
            data-sizes="auto" 
            class=" img-responsive lazyload tnt-prop-img"
            alt=""></a></div></section></div><div id="tncms-block-1305562" class="tncms-block"><section id="block-1305562" class="block emphasis-h4   " ><div class="clearfix">
    
    <div class="block-title title-1305562 ">
        <div class="block-title-inner">
            <h4>
                
                Contact Information
                
            </h4>
        </div>
    </div></div><address>
    <strong>rocketminer.com</strong><br>
    215 D Street<br>
    Rock Springs, WY 82901
    <br>
    
        <strong>Phone:</strong> 307-362-3736<br>
        <strong>Email:</strong> <a href="mailto:editor@rocketminer.com">editor@rocketminer.com</a><br>
    
</address></section></div><div id="tncms-block-1305570" class="tncms-block padding-bottom"><div class="follow-links-1305570 default">
    
    <section id="block-1305570" class="block emphasis-h4   " ><ul class="list-inline">
        
            <li>
                <a href="https://www.facebook.com/rocketminernewspaper/" title="Facebook" target="_blank" rel="noopener" class="btn btn-xs btn-link fb" data-toggle="tooltip" data-placement="bottom">
                    <i class="fab tnt-facebook-f"></i>
                    <span class="sr-only">Facebook</span>
                </a>
            </li>
        
        
            <li>
                <a href="http://twitter.com/Rocket_Miner/" title="Twitter" target="_blank" rel="noopener" class="btn btn-xs btn-link tw" data-toggle="tooltip" data-placement="bottom">
                    <i class="fab tnt-twitter"></i>
                    <span class="sr-only">Twitter</span>
                </a>
            </li>
        
        
        
            <li>
                <a href="https://www.youtube.com/channel/UCkIJ3w8D5mYUsoC_nIKJyBQ" title="Youtube" target="_blank" rel="noopener" class="btn btn-xs btn-link yt" data-toggle="tooltip" data-placement="bottom">
                    <i class="fab tnt-youtube"></i>
                    <span class="sr-only">YouTube</span>
                </a>
            </li>
        
        
        
        
        
        
        
        
        
        
        
        
        
        
    </ul>
    </section>
</div>
<script type="application/ld+json">
{ "@context" : "https://schema.org",
  "@type" : "Organization",
  "url" : "http://www.rocketminer.com",
  "sameAs" : ["https://www.facebook.com/rocketminernewspaper/","http://twitter.com/Rocket_Miner/","https://www.youtube.com/channel/UCkIJ3w8D5mYUsoC_nIKJyBQ"]
}
</script>
<div class="clearfix"></div></div></div></div>
                </div>
                <div id="tncms-region-footer-bottom-col-full" class="tncms-region "></div>
                
            </footer>
        

        <div id="site-copyright-container" class="container">
            <div id="tncms-region-footer-copyright" class="tncms-region "><div id="tncms-block-1305487" class="tncms-block"><div id="site-copyright" class="row">
    <section id="block-1305487"><div class="col-md-7"><small>&copy; Copyright 2019 <a href="/">rocketminer.com</a>, 215 D Street Rock Springs, WY</small><small>&nbsp;| <a href="/site/privacy.html">Privacy Policy</a></small></div>
        <div class="col-md-5"><small>Powered by <a href="https://bloxcms.com" title="BLOX Content Management System" target="_blank" rel="noopener">BLOX Content Management System</a> from <a href="https://townnews.com/" title="TownNews.com BLOX Newspaper Content Management" target="_blank" rel="noopener">TownNews.com</a>.</small></div>
    </section>
</div></div></div>
        </div>
    </div>
    
    
        </div><!-- / offcanvas close  -->
    

    
    
    <!-- / site-container close -->
    </div>
    
    
    <script>
window.__tnt || (window.__tnt = {});
__tnt.compatibility || (__tnt.compatibility = {});

__tnt.compatibility.status = "";
__tnt.compatibility.check = function(){
    var compatible = true;
    var status = "";

    if(typeof(__tnt.advertisements)=="undefined"){
        compatible = false;
        status += "FAIL: object 0 undefined "
    }

    __tnt.compatibility.status = status;
    return compatible;
}
__tnt.compatibility.notification = function(){
}

$(function(){
    if(!__tnt.compatibility.check()){
        if(window.ga){
            __tnt.trackEvent({'category':'subscription','action':'adblock','label':'adblock detected','value':'1'});
        }
        
        __tnt.compatibility.notification();
    }
});
</script>

    
    <script>
        jQuery(function() {
            if(typeof TNCMS.Tracking != 'undefined'){
                jQuery(TNCMS.Tracking.trackDeclarativeEvents);
            }
        });
    </script>
<script>
        __tnt.trackEvent = function(obj) {
            if( jQuery.type(obj) === 'object' ){
                 
                    if(obj.category && obj.action){
                        __tnt.googleEvent(obj);
                    } else if(obj.network && obj.socialAction){
                        __tnt.googleSocial(obj);
                    } else if(obj.url){
                        __tnt.googlePageView(obj);
                    }
                    if(typeof TNCMS.Tracking != 'undefined' && obj.metric){
                        TNCMS.Tracking.addEvent({
                            app: obj.app,
                            metric: obj.metric,
                            id: obj.uuid
                        });
                    }
                
            }
        }
        
        if(__tnt.trackEventLater.length > 0){
            jQuery(__tnt.trackEventLater).each(function(){
                __tnt.trackEvent($(this));
            });
        }
        jQuery('body').on(__tnt.client.clickEvent, '[data-track]', function(){
            var trkObj = jQuery(this).data('track');
            __tnt.trackEvent(trkObj);
        });
        jQuery('body').on(__tnt.client.clickEvent, '[data-tncms-track-event]', function(){
            var trkObj = jQuery(this).data('tncms-track-event');
            __tnt.trackEvent(trkObj);
        });
        jQuery('body').on(__tnt.client.clickEvent, '[data-tncms-track-dmp]', function(){
            var dmpData = jQuery(this).data('tncms-track-dmp');
            });
    </script>
    
<script>/*<![CDATA[*/ 
                __tnt.googleEvent = function(obj) {
                    dataLayer.push({
                        'event': 'tncms.event.trigger',
                             'tncms.event.trigger.category': obj.category,
                             'tncms.event.trigger.action': obj.action,
                             'tncms.event.trigger.label': obj.label, 
                             'tncms.event.trigger.value': obj.value
                    });
                }
                /* Virtual page view */
                __tnt.googlePageView = function(obj) {
                    var sURL = obj.url.replace(/^.*\/\/[^\/]+/, '');
                    dataLayer.push({
                        'event': 'tncms.event.virtual_pageview',
                            'tncms.event.virtual_pageview.url': sURL,
                            'tncms.event.virtual_pageview.title': obj.title
                    });
                }
                /* Social event */
                __tnt.googleSocial = function(obj) {
                    dataLayer.push({
                        'event': 'tncms.event.social',
                            'tncms.event.social.network': obj.network,
                            'tncms.event.social.action': obj.socialAction,
                            'tncms.event.social.target': obj.url
                    });
                } /*]]>*/</script>
<script>/*<![CDATA[*/ $(function() {
        var avatar_1305572 = $('#user-controls-1305572 .tn-user-avatar');
        if(__tnt.user.loggedIn && __tnt.user.avatar){
            avatar_1305572.append('<img src="' + __tnt.user.avatar + '" class="user-icon">');
        } else{
            avatar_1305572.append('<i class="fas tnt-user tnt-fw user-icon"></i>');
        }
    }); /*]]>*/</script>
<script>/*<![CDATA[*/ $(function() {
        var avatar_1305571 = $('#user-controls-1305571 .tn-user-avatar');
        if(__tnt.user.loggedIn && __tnt.user.avatar){
            avatar_1305571.append('<img src="' + __tnt.user.avatar + '" class="user-icon">');
        } else{
            avatar_1305571.append('<i class="fas tnt-user tnt-fw user-icon"></i>');
        }
    }); /*]]>*/</script>
<script>/*<![CDATA[*/ 
            window._taboola = window._taboola || [];
            _taboola.push({article:'auto'});
            !function (e, f, u, i) {
                if (!document.getElementById(i)){
                    e.async = 1;
                    e.src = u;
                    e.id = i;
                    f.parentNode.insertBefore(e, f);
                }
            }(document.createElement('script'),
            document.getElementsByTagName('script')[0],
                '//cdn.taboola.com/libtrc/townnews-network/loader.js',
                'tb_loader_script');
            if(window.performance && typeof window.performance.mark == 'function')
                {window.performance.mark('tbl_ic');}
        
                        window._taboola = window._taboola || [];
                        _taboola.push({
                            mode: 'thumbnails-a',
                            container: 'taboola-below-article-thumbnails',
                            placement: 'Below Article Thumbnails',
                            target_type: 'mix'
                        });
                    
                        window._taboola = window._taboola || [];
                        _taboola.push({
                            mode: 'hybrid-text-links-a',
                            container: 'taboola-below-article-text-links',
                            placement: 'Below Article Text Links',
                            target_type: 'mix'
                        });
                    
              window._taboola = window._taboola || [];
              _taboola.push({flush: true});
         /*]]>*/</script>
<script>/*<![CDATA[*/ (function (a, c, s, u){'Insticator'in a || (a.Insticator={ad:{loadAd: function (b){Insticator.ad.q.push(b)}, q: []}, helper:{}, embed:{}, version: '3.0', q: [], load: function (t, o){Insticator.q.push({t: t, o: o})}}); var b=c.createElement(s); b.src=u; b.async=!0; var d=c.getElementsByTagName(s)[0]; d.parentNode.insertBefore(b, d)})(window, document, 'script', '//d2na2p72vtqyok.cloudfront.net/client-embed/b1ad8512-0208-404a-8bef-42066664235a.js');
                /*&lt;![CDATA[[*/Insticator.ad.loadAd('div-insticator-ad-1');Insticator.ad.loadAd('div-insticator-ad-2');Insticator.load('em',{id:'40c1ddd3-f53e-4cc2-99cf-8551b04a81fa'})/*]]&gt;*/ /*]]>*/</script></body>
</html>